aboutsummaryrefslogtreecommitdiffstats
path: root/package/pptp
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
commit5a325930579db5f9175bea19459c845746801ae4 (patch)
tree8b63e203323c3c4ab05aa9bf0a9ec17f5dc87c91 /package/pptp
parent7bc567a0409f4d9aa9a4e12e9c56bc892b737da3 (diff)
downloadmaster-187ad058-5a325930579db5f9175bea19459c845746801ae4.tar.gz
master-187ad058-5a325930579db5f9175bea19459c845746801ae4.tar.bz2
master-187ad058-5a325930579db5f9175bea19459c845746801ae4.zip
replace lots of manual install commands with INSTALL_* variables
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5624 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/pptp')
-rw-r--r--package/pptp/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/pptp/Makefile b/package/pptp/Makefile
index bb0710419b..081ff4e52a 100644
--- a/package/pptp/Makefile
+++ b/package/pptp/Makefile
@@ -31,12 +31,12 @@ define Package/pptp
endef
define Package/pptp/install
- install -d -m0755 $(1)/usr/sbin
- install -m0755 $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
- install -d -m0755 $(1)/etc/ppp
- install -m0644 ./files/options.pptp $(1)/etc/ppp/
- install -d -m0755 $(1)/lib/network
- install -m0755 ./files/pptp.sh $(1)/lib/network/
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
+ $(INSTALL_DIR) $(1)/etc/ppp
+ $(INSTALL_DATA) ./files/options.pptp $(1)/etc/ppp/
+ $(INSTALL_DIR) $(1)/lib/network
+ $(INSTALL_BIN) ./files/pptp.sh $(1)/lib/network/
endef
$(eval $(call BuildPackage,pptp))