aboutsummaryrefslogtreecommitdiffstats
path: root/package/postgresql
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-05-12 21:32:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-05-12 21:32:55 +0000
commitcb8dcb8dbdc7afc05002170523efd39bc80cfcff (patch)
tree4e012de42decaf04feaf1c5d92533873560f1e94 /package/postgresql
parenta43a27ddfab12cc774a0cc650667eaaa096cdab3 (diff)
downloadmaster-187ad058-cb8dcb8dbdc7afc05002170523efd39bc80cfcff.tar.gz
master-187ad058-cb8dcb8dbdc7afc05002170523efd39bc80cfcff.tar.bz2
master-187ad058-cb8dcb8dbdc7afc05002170523efd39bc80cfcff.zip
fix postgres build with gcc 3.4+
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@860 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/postgresql')
-rw-r--r--package/postgresql/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/package/postgresql/Makefile b/package/postgresql/Makefile
index 592d4cc346..5c0226646f 100644
--- a/package/postgresql/Makefile
+++ b/package/postgresql/Makefile
@@ -22,11 +22,6 @@ IPKG_LIBPQ:=$(PACKAGE_DIR)/libpq_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
IDIR_LIBPQ:=$(PKG_BUILD_DIR)/ipkg
INFO_LIBPQ:=$(IPKG_STATE_DIR)/info/libpq.list
-EXTRA_CFLAGS:=
-ifeq ($(BR2_GCC_3_4),y)
- EXTRA_CFLAGS += -fno-unit-at-a-time
-endif
-
$(DL_DIR)/$(PKG_SOURCE):
$(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
@@ -82,14 +77,16 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
touch $(PKG_BUILD_DIR)/.configured
$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
- $(MAKE) -C "$(PKG_BUILD_DIR)" \
- $(TARGET_CONFIGURE_OPTS)
+ $(MAKE) -C "$(PKG_BUILD_DIR)/src" \
+ $(TARGET_CONFIGURE_OPTS) \
+ submake-libpq
touch $(PKG_BUILD_DIR)/.built
$(STAGING_DIR)/usr/lib/libpq.so: $(PKG_BUILD_DIR)/.built
$(MAKE) -C "$(PKG_BUILD_DIR)" \
DESTDIR="$(STAGING_DIR)" \
- install
+ install-all-headers
+ cp -a $(PKG_BUILD_DIR)/src/interfaces/libpq/libpq.so* $(STAGING_DIR)/usr/lib
$(IPKG_LIBPQ): $(STAGING_DIR)/usr/lib/libpq.so
$(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_LIBPQ) ./ipkg/libpq.control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)