aboutsummaryrefslogtreecommitdiffstats
path: root/package/openvpn/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-04-03 21:36:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-04-03 21:36:01 +0000
commit5d45603b1f279df9f784ee10b4bbc43c2f139a0c (patch)
treedbb92b77cfec4cd15aa4670ceb8511cde1bf635b /package/openvpn/Makefile
parentd486b611aca841065dcad5daefb78f59b03bfe81 (diff)
downloadmaster-187ad058-5d45603b1f279df9f784ee10b4bbc43c2f139a0c.tar.gz
master-187ad058-5d45603b1f279df9f784ee10b4bbc43c2f139a0c.tar.bz2
master-187ad058-5d45603b1f279df9f784ee10b4bbc43c2f139a0c.zip
make lzo and server support in openvpn optional
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@551 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/openvpn/Makefile')
-rw-r--r--package/openvpn/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/openvpn/Makefile b/package/openvpn/Makefile
index bab2528906..991e52f9e1 100644
--- a/package/openvpn/Makefile
+++ b/package/openvpn/Makefile
@@ -14,6 +14,14 @@ PKG_CAT:=zcat
PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
+ifneq ($(BR2_PACKAGE_OPENVPN_LZO),y)
+DISABLE_LZO:=--disable-lzo
+endif
+
+ifneq ($(BR2_PACKAGE_OPENVPN_SERVER),y)
+DISABLE_SERVER:=--disable-server
+endif
+
$(DL_DIR)/$(PKG_SOURCE):
$(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
@@ -46,6 +54,8 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.unpacked
--disable-management \
--disable-socks \
--disable-http \
+ $(DISABLE_LZO) \
+ $(DISABLE_SERVER) \
);
touch $(PKG_BUILD_DIR)/.configured