aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-22 04:15:33 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-22 04:15:33 +0000
commit1ab80109762686efdda43d0f126e82fd2aa56116 (patch)
tree89e4be7bf401fe9ac6ad624a53ae8a53e8cbf971 /package/openssl/Makefile
parent5da7865476007016dd520a0f31afb027be216f37 (diff)
downloadmaster-187ad058-1ab80109762686efdda43d0f126e82fd2aa56116.tar.gz
master-187ad058-1ab80109762686efdda43d0f126e82fd2aa56116.tar.bz2
master-187ad058-1ab80109762686efdda43d0f126e82fd2aa56116.zip
install OpenSSL pkgconfig dev files
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8941 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/openssl/Makefile')
-rw-r--r--package/openssl/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index 0f8ba5acaf..36b5b24e27 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -113,11 +113,17 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/include/openssl $(STAGING_DIR)/usr/include/
mkdir -p $(STAGING_DIR)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(STAGING_DIR)/usr/lib/
+ mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+ $(SED) 's,^includedir=.*,includedir=$(STAGING_DIR)/usr/include,g' $(STAGING_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
+ $(SED) 's,^libdir=.*,libdir=$(STAGING_DIR)/usr/lib,g' $(STAGING_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
+ $(SED) 's,$(TARGET_LDFLAGS),,g' $(STAGING_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
endef
define Build/UninstallDev
rm -rf $(STAGING_DIR)/usr/include/openssl \
- $(STAGING_DIR)/usr/lib/lib{crypto,ssl}.{a,so*}
+ $(STAGING_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} \
+ $(STAGING_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
endef
define Package/libopenssl/install