aboutsummaryrefslogtreecommitdiffstats
path: root/package/openldap
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-08-10 16:06:24 +0000
committerNicolas Thill <nico@openwrt.org>2005-08-10 16:06:24 +0000
commiteccc8e9b8572057c6d0d5893bc95e151a9be7076 (patch)
treeb97901ef3f7cc44a098458b2f76056e24db0ef43 /package/openldap
parent4b30f2c041d2983c5c8707b004589ea085ac2abb (diff)
downloadmaster-187ad058-eccc8e9b8572057c6d0d5893bc95e151a9be7076.tar.gz
master-187ad058-eccc8e9b8572057c6d0d5893bc95e151a9be7076.tar.bz2
master-187ad058-eccc8e9b8572057c6d0d5893bc95e151a9be7076.zip
Fix building when host and target systems are same arch
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1597 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/openldap')
-rw-r--r--package/openldap/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/openldap/Makefile b/package/openldap/Makefile
index 35a15b37e2..20179b2719 100644
--- a/package/openldap/Makefile
+++ b/package/openldap/Makefile
@@ -78,7 +78,7 @@ $(PKG_BUILD_DIR)/.built:
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+ LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
ac_cv_func_memcmp_clean="yes" \
./configure \
--target=$(GNU_TARGET_NAME) \
@@ -128,7 +128,7 @@ $(STAGING_DIR)/usr/lib/libldap.so: $(PKG_BUILD_DIR)/.built
cp -fpR $(PKG_INSTALL_DIR)/usr/include/{lber,ldap}*.h $(STAGING_DIR)/usr/include/
mkdir -p $(STAGING_DIR)/usr/lib/
cp -fpR $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.{a,so*} $(STAGING_DIR)/usr/lib/
- touch $(STAGING_DIR)/usr/lib/libldap.so
+ touch $@
install-dev: $(STAGING_DIR)/usr/lib/libldap.so