aboutsummaryrefslogtreecommitdiffstats
path: root/package/nvram
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-28 01:45:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-28 01:45:11 +0000
commitbb6c4aade1c3174895429f168d4eac7a67d312cd (patch)
treeeb4212ed9fc412f6018213aec05fae3059ed20bf /package/nvram
parent499485004b52b5960c950922fb1dedcedd0923fa (diff)
downloadmaster-187ad058-bb6c4aade1c3174895429f168d4eac7a67d312cd.tar.gz
master-187ad058-bb6c4aade1c3174895429f168d4eac7a67d312cd.tar.bz2
master-187ad058-bb6c4aade1c3174895429f168d4eac7a67d312cd.zip
add $(STAGING_DIR) as argument to the InstallDev template and update packages accordingly - this way we can reuse InstallDev to automatically generate UninstallDev or create -dev packages
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9052 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/nvram')
-rw-r--r--package/nvram/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/nvram/Makefile b/package/nvram/Makefile
index cc1371ec64..2bcc3afcf4 100644
--- a/package/nvram/Makefile
+++ b/package/nvram/Makefile
@@ -30,12 +30,12 @@ define Build/Prepare
endef
define Build/InstallDev
- mkdir -p $(STAGING_DIR)/usr/lib
- $(CP) $(PKG_BUILD_DIR)/lib{nvram,shared}*.so $(STAGING_DIR)/usr/lib/
+ mkdir -p $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/lib{nvram,shared}*.so $(1)/usr/lib/
endef
define Build/UninstallDev
- rm -f $(STAGING_DIR)/usr/lib/lib{nvram,shared}*.so
+ rm -f $(1)/usr/lib/lib{nvram,shared}*.so
endef
define Package/nvram/install