aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2014-09-29 18:00:02 +0000
committerSteven Barth <steven@midlink.org>2014-09-29 18:00:02 +0000
commit2fceef90179d12c2fb77fdd977b8e70d3f76c5f1 (patch)
tree3701a0227cf7da30f412e89c87059bf67b25dbc5 /package/network
parent696b5c1e57aa73794ffa2dc4834a04d9bb0481a2 (diff)
downloadmaster-187ad058-2fceef90179d12c2fb77fdd977b8e70d3f76c5f1.tar.gz
master-187ad058-2fceef90179d12c2fb77fdd977b8e70d3f76c5f1.tar.bz2
master-187ad058-2fceef90179d12c2fb77fdd977b8e70d3f76c5f1.zip
GRE: Tos support
Tos support is added as a generic grev4/grev6 parameter which can have the following values : -inherit (outer header inherits the tos value of the inner header) -hex value Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42700 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network')
-rw-r--r--package/network/config/gre/Makefile2
-rwxr-xr-xpackage/network/config/gre/files/gre.sh6
2 files changed, 5 insertions, 3 deletions
diff --git a/package/network/config/gre/Makefile b/package/network/config/gre/Makefile
index 9f5135e5a5..9c5c13f169 100644
--- a/package/network/config/gre/Makefile
+++ b/package/network/config/gre/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gre
PKG_VERSION:=1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/config/gre/files/gre.sh b/package/network/config/gre/files/gre.sh
index 1728b01fcc..4483a08787 100755
--- a/package/network/config/gre/files/gre.sh
+++ b/package/network/config/gre/files/gre.sh
@@ -13,8 +13,8 @@ gre_generic_setup() {
local local="$3"
local remote="$4"
local link="$5"
- local mtu ttl zone ikey okey icsum ocsum iseqno oseqno
- json_get_vars mtu ttl zone ikey okey icsum ocsum iseqno oseqno
+ local mtu ttl tos zone ikey okey icsum ocsum iseqno oseqno
+ json_get_vars mtu ttl tos zone ikey okey icsum ocsum iseqno oseqno
[ -z "$zone" ] && zone="wan"
@@ -25,6 +25,7 @@ gre_generic_setup() {
json_add_int mtu "${mtu:-1280}"
[ -n "$df" ] && json_add_boolean df "$df"
json_add_int ttl "${ttl:-64}"
+ [ -n "$tos" ] && json_add_string tos "$tos"
json_add_string local "$local"
json_add_string remote "$remote"
[ -n "$tunlink" ] && json_add_string link "$tunlink"
@@ -193,6 +194,7 @@ gre_generic_init_config() {
proto_config_add_int "mtu"
proto_config_add_int "ttl"
+ proto_config_add_string "tos"
proto_config_add_string "tunlink"
proto_config_add_string "zone"
proto_config_add_int "ikey"