aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-02-01 18:04:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-02-01 18:04:00 +0000
commit095264f9402129ec7e554e44161aada79a2d00c5 (patch)
tree413f616d91847e3d17a0ebffd06347664511c428 /package/network
parent11a3fbb551af93738c82ea22534a429e8a2c23f4 (diff)
downloadmaster-187ad058-095264f9402129ec7e554e44161aada79a2d00c5.tar.gz
master-187ad058-095264f9402129ec7e554e44161aada79a2d00c5.tar.bz2
master-187ad058-095264f9402129ec7e554e44161aada79a2d00c5.zip
iproute2: refresh patches
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48613 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network')
-rw-r--r--package/network/utils/iproute2/patches/006-no_sctp.patch6
-rw-r--r--package/network/utils/iproute2/patches/007-no_arpd.patch11
-rw-r--r--package/network/utils/iproute2/patches/008-no_netem.patch5
-rw-r--r--package/network/utils/iproute2/patches/110-extra-ccopts.patch3
-rw-r--r--package/network/utils/iproute2/patches/120-libnetlink-pic.patch6
-rw-r--r--package/network/utils/iproute2/patches/130-missing_include.patch2
-rw-r--r--package/network/utils/iproute2/patches/300-ip_tiny.patch12
-rw-r--r--package/network/utils/iproute2/patches/900-drop_FAILED_POLICY.patch2
-rw-r--r--package/network/utils/iproute2/patches/911-fix_in_h_include.patch10
9 files changed, 28 insertions, 29 deletions
diff --git a/package/network/utils/iproute2/patches/006-no_sctp.patch b/package/network/utils/iproute2/patches/006-no_sctp.patch
index 4aa988415e..6805468d81 100644
--- a/package/network/utils/iproute2/patches/006-no_sctp.patch
+++ b/package/network/utils/iproute2/patches/006-no_sctp.patch
@@ -1,6 +1,6 @@
--- a/ip/ipxfrm.c
+++ b/ip/ipxfrm.c
-@@ -467,7 +467,6 @@ void xfrm_selector_print(struct xfrm_sel
+@@ -470,7 +470,6 @@ void xfrm_selector_print(struct xfrm_sel
switch (sel->proto) {
case IPPROTO_TCP:
case IPPROTO_UDP:
@@ -8,11 +8,11 @@
case IPPROTO_DCCP:
default: /* XXX */
if (sel->sport_mask)
-@@ -1337,7 +1336,6 @@ static int xfrm_selector_upspec_parse(st
+@@ -1341,7 +1340,6 @@ static int xfrm_selector_upspec_parse(st
switch (sel->proto) {
case IPPROTO_TCP:
case IPPROTO_UDP:
- case IPPROTO_SCTP:
case IPPROTO_DCCP:
+ case IPPROTO_IP: /* to allow shared SA for different protocols */
break;
- default:
diff --git a/package/network/utils/iproute2/patches/007-no_arpd.patch b/package/network/utils/iproute2/patches/007-no_arpd.patch
index d33dfe60d9..94fb197a45 100644
--- a/package/network/utils/iproute2/patches/007-no_arpd.patch
+++ b/package/network/utils/iproute2/patches/007-no_arpd.patch
@@ -1,16 +1,15 @@
--- a/misc/Makefile
+++ b/misc/Makefile
-@@ -5,9 +5,9 @@
-
+@@ -5,9 +5,9 @@ TARGETS=ss nstat ifstat rtacct lnstat
+
include ../Config
-
+
-ifeq ($(HAVE_BERKELEY_DB),y)
- TARGETS += arpd
-endif
+#ifeq ($(HAVE_BERKELEY_DB),y)
+# TARGETS += arpd
+#endif
-
+
ifeq ($(HAVE_SELINUX),y)
- LDLIBS += $(shell pkg-config --libs libselinux)
-
+ LDLIBS += $(shell $(PKG_CONFIG) --libs libselinux)
diff --git a/package/network/utils/iproute2/patches/008-no_netem.patch b/package/network/utils/iproute2/patches/008-no_netem.patch
index 232a6ea973..fce16e02df 100644
--- a/package/network/utils/iproute2/patches/008-no_netem.patch
+++ b/package/network/utils/iproute2/patches/008-no_netem.patch
@@ -3,10 +3,9 @@
@@ -41,7 +41,7 @@ WFLAGS += -Wmissing-declarations -Wold-s
CFLAGS := $(WFLAGS) $(CCOPTS) -I../include $(DEFINES) $(CFLAGS)
YACCFLAGS = -d -t -v
-
+
-SUBDIRS=lib ip tc bridge misc netem genl tipc man
+SUBDIRS=lib ip tc bridge misc genl tipc man
-
+
LIBNETLINK=../lib/libnetlink.a ../lib/libutil.a
LDLIBS += $(LIBNETLINK)
-
diff --git a/package/network/utils/iproute2/patches/110-extra-ccopts.patch b/package/network/utils/iproute2/patches/110-extra-ccopts.patch
index 611b1bce61..3cb5a79400 100644
--- a/package/network/utils/iproute2/patches/110-extra-ccopts.patch
+++ b/package/network/utils/iproute2/patches/110-extra-ccopts.patch
@@ -1,6 +1,6 @@
--- a/Makefile
+++ b/Makefile
-@@ -34,7 +34,7 @@ ADDLIB+=ipx_ntop.o ipx_pton.o
+@@ -34,7 +34,7 @@ HOSTCC = gcc
DEFINES += -D_GNU_SOURCE
# Turn on transparent support for LFS
DEFINES += -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
@@ -8,3 +8,4 @@
+CCOPTS = -O2 $(EXTRA_CCOPTS)
WFLAGS := -Wall -Wstrict-prototypes -Wmissing-prototypes
WFLAGS += -Wmissing-declarations -Wold-style-definition -Wformat=2
+
diff --git a/package/network/utils/iproute2/patches/120-libnetlink-pic.patch b/package/network/utils/iproute2/patches/120-libnetlink-pic.patch
index 19ccd1a936..1f397f71b2 100644
--- a/package/network/utils/iproute2/patches/120-libnetlink-pic.patch
+++ b/package/network/utils/iproute2/patches/120-libnetlink-pic.patch
@@ -1,11 +1,11 @@
--- a/lib/Makefile
+++ b/lib/Makefile
@@ -4,7 +4,7 @@ ifeq ($(IP_CONFIG_SETNS),y)
- CFLAGS += -DHAVE_SETNS
+ CFLAGS += -DHAVE_SETNS
endif
-CFLAGS += -fPIC
+CFLAGS += $(FPIC)
- UTILOBJ=utils.o rt_names.o ll_types.o ll_proto.o ll_addr.o inet_proto.o namespace.o \
- names.o
+ UTILOBJ = utils.o rt_names.o ll_types.o ll_proto.o ll_addr.o \
+ inet_proto.o namespace.o json_writer.o \
diff --git a/package/network/utils/iproute2/patches/130-missing_include.patch b/package/network/utils/iproute2/patches/130-missing_include.patch
index 6dc63e4128..88dfd8585f 100644
--- a/package/network/utils/iproute2/patches/130-missing_include.patch
+++ b/package/network/utils/iproute2/patches/130-missing_include.patch
@@ -5,6 +5,6 @@
#include <dirent.h>
#include <limits.h>
+#include <sys/param.h>
-
+
#include "utils.h"
#include "namespace.h"
diff --git a/package/network/utils/iproute2/patches/300-ip_tiny.patch b/package/network/utils/iproute2/patches/300-ip_tiny.patch
index c0ebfd3ce5..290adbe5f5 100644
--- a/package/network/utils/iproute2/patches/300-ip_tiny.patch
+++ b/package/network/utils/iproute2/patches/300-ip_tiny.patch
@@ -1,6 +1,6 @@
--- a/ip/Makefile
+++ b/ip/Makefile
-@@ -16,6 +16,13 @@ ifeq ($(IP_CONFIG_SETNS),y)
+@@ -17,6 +17,13 @@ ifeq ($(IP_CONFIG_SETNS),y)
CFLAGS += -DHAVE_SETNS
endif
@@ -14,7 +14,7 @@
ALLOBJ=$(IPOBJ) $(RTMONOBJ)
SCRIPTS=ifcfg rtpr routel routef
TARGETS=ip rtmon
-@@ -43,7 +50,7 @@ else
+@@ -44,7 +51,7 @@ else
ip: static-syms.o
static-syms.o: static-syms.h
@@ -70,7 +70,7 @@
};
--- a/lib/utils.c
+++ b/lib/utils.c
-@@ -675,6 +675,7 @@ const char *rt_addr_n2a(int af, int len,
+@@ -710,6 +710,7 @@ const char *rt_addr_n2a(int af, int len,
return inet_ntop(af, addr, buf, buflen);
case AF_MPLS:
return mpls_ntop(af, addr, buf, buflen);
@@ -78,7 +78,7 @@
case AF_IPX:
return ipx_ntop(af, addr, buf, buflen);
case AF_DECnet:
-@@ -683,6 +684,7 @@ const char *rt_addr_n2a(int af, int len,
+@@ -718,6 +719,7 @@ const char *rt_addr_n2a(int af, int len,
memcpy(dna.a_addr, addr, 2);
return dnet_ntop(af, &dna, buf, buflen);
}
@@ -89,7 +89,7 @@
--- a/lib/Makefile
+++ b/lib/Makefile
@@ -4,6 +4,10 @@ ifeq ($(IP_CONFIG_SETNS),y)
- CFLAGS += -DHAVE_SETNS
+ CFLAGS += -DHAVE_SETNS
endif
+ifeq ($(IP_CONFIG_TINY),y)
@@ -98,4 +98,4 @@
+
CFLAGS += $(FPIC)
- UTILOBJ=utils.o rt_names.o ll_types.o ll_proto.o ll_addr.o inet_proto.o namespace.o \
+ UTILOBJ = utils.o rt_names.o ll_types.o ll_proto.o ll_addr.o \
diff --git a/package/network/utils/iproute2/patches/900-drop_FAILED_POLICY.patch b/package/network/utils/iproute2/patches/900-drop_FAILED_POLICY.patch
index f5d2dfe9b9..ff2e0aa1ee 100644
--- a/package/network/utils/iproute2/patches/900-drop_FAILED_POLICY.patch
+++ b/package/network/utils/iproute2/patches/900-drop_FAILED_POLICY.patch
@@ -24,7 +24,7 @@ Subject: [PATCH] add support for dropping with FAILED_POLICY
--- a/include/linux/rtnetlink.h
+++ b/include/linux/rtnetlink.h
-@@ -208,6 +208,7 @@ enum {
+@@ -210,6 +210,7 @@ enum {
RTN_THROW, /* Not in this table */
RTN_NAT, /* Translate this address */
RTN_XRESOLVE, /* Use external resolver */
diff --git a/package/network/utils/iproute2/patches/911-fix_in_h_include.patch b/package/network/utils/iproute2/patches/911-fix_in_h_include.patch
index cce086c3e5..42a7b24bbb 100644
--- a/package/network/utils/iproute2/patches/911-fix_in_h_include.patch
+++ b/package/network/utils/iproute2/patches/911-fix_in_h_include.patch
@@ -1,16 +1,16 @@
--- a/include/linux/in.h
+++ b/include/linux/in.h
@@ -15,6 +15,7 @@
- * as published by the Free Software Foundation; either version
- * 2 of the License, or (at your option) any later version.
+ * as published by the Free Software Foundation; either version
+ * 2 of the License, or (at your option) any later version.
*/
+#ifndef _NETINET_IN_H
#ifndef _LINUX_IN_H
#define _LINUX_IN_H
-
+
@@ -297,3 +298,4 @@ struct sockaddr_in {
-
-
+
+
#endif /* _LINUX_IN_H */
+#endif /* _NETINET_IN_H */
--- a/include/linux/in6.h