aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-19 11:58:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-19 11:58:17 +0000
commit2b33958d7091872d10946b41e33828b2e27fc3b6 (patch)
treea7053ae6cec31ba26f227fd7ec2c082467870210 /package/network/utils
parentecc294e76c805c9183cf472a9d0bb9e95c2e8afa (diff)
downloadmaster-187ad058-2b33958d7091872d10946b41e33828b2e27fc3b6.tar.gz
master-187ad058-2b33958d7091872d10946b41e33828b2e27fc3b6.tar.bz2
master-187ad058-2b33958d7091872d10946b41e33828b2e27fc3b6.zip
ipset: use in-tree kernel modules to fix crash issues
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44883 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils')
-rw-r--r--package/network/utils/ipset/Makefile26
1 files changed, 0 insertions, 26 deletions
diff --git a/package/network/utils/ipset/Makefile b/package/network/utils/ipset/Makefile
index 14a47afbec..f1c50a90da 100644
--- a/package/network/utils/ipset/Makefile
+++ b/package/network/utils/ipset/Makefile
@@ -39,25 +39,8 @@ MAKE_FLAGS += \
ARCH="$(LINUX_KARCH)" \
SHELL="$(BASH)"
-IPSET_MODULES:= \
- ipset/ip_set \
- ipset/ip_set_bitmap_ip \
- ipset/ip_set_bitmap_ipmac \
- ipset/ip_set_bitmap_port \
- ipset/ip_set_hash_ip \
- ipset/ip_set_hash_ipmark \
- ipset/ip_set_hash_ipport \
- ipset/ip_set_hash_ipportip \
- ipset/ip_set_hash_ipportnet \
- ipset/ip_set_hash_net \
- ipset/ip_set_hash_netiface \
- ipset/ip_set_hash_netport \
- ipset/ip_set_list_set \
- xt_set \
-
define Build/Compile
$(call Build/Compile/Default)
- $(call Build/Compile/Default,modules)
endef
define Package/ipset/install
@@ -67,13 +50,4 @@ define Package/ipset/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libipset*.so* $(1)/usr/lib/
endef
-define KernelPackage/ipt-ipset
- SUBMENU:=Netfilter Extensions
- TITLE:=IPset netfilter modules
- DEPENDS+= +kmod-ipt-core +kmod-nfnetlink
- FILES:=$(foreach mod,$(IPSET_MODULES),$(PKG_BUILD_DIR)/kernel/net/netfilter/$(mod).ko)
- AUTOLOAD:=$(call AutoLoad,49,$(notdir $(IPSET_MODULES)))
-endef
-
$(eval $(call BuildPackage,ipset))
-$(eval $(call KernelPackage,ipt-ipset))