aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/xtables-addons
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-07-19 09:58:11 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-07-19 09:58:11 +0000
commit8101167ca42b601d26edcae1b9f816f9f977127f (patch)
tree126556bfdaa27b41eb3b2673d2d293dd3528c9f2 /package/network/utils/xtables-addons
parent2c12f6c298f4bd4846d59a124c78cc87ee0e1592 (diff)
downloadmaster-187ad058-8101167ca42b601d26edcae1b9f816f9f977127f.tar.gz
master-187ad058-8101167ca42b601d26edcae1b9f816f9f977127f.tar.bz2
master-187ad058-8101167ca42b601d26edcae1b9f816f9f977127f.zip
xtables-addons: add missing kmod dependencies
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37424 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/xtables-addons')
-rw-r--r--package/network/utils/xtables-addons/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/network/utils/xtables-addons/Makefile b/package/network/utils/xtables-addons/Makefile
index 44cd272ea4..964879e354 100644
--- a/package/network/utils/xtables-addons/Makefile
+++ b/package/network/utils/xtables-addons/Makefile
@@ -132,14 +132,14 @@ endef
$(eval $(call BuildTemplate,compat-xtables,API compatibilty layer,,compat_xtables,45,,CONFIG_NF_CONNTRACK_MARK=y))
$(eval $(call BuildTemplate,rawpost,RAWPOST,,iptable_rawpost $(if $(CONFIG_IPV6),ip6table_rawpost),50,+kmod-ipt-compat-xtables +IPV6:kmod-ip6tables))
-$(eval $(call BuildTemplate,nathelper-rtsp,RTSP Conntrack and NAT,,rtsp/nf_conntrack_rtsp rtsp/nf_nat_rtsp,46,+kmod-ipt-conntrack-extra))
+$(eval $(call BuildTemplate,nathelper-rtsp,RTSP Conntrack and NAT,,rtsp/nf_conntrack_rtsp rtsp/nf_nat_rtsp,46,+kmod-ipt-conntrack-extra +kmod-ipt-nat))
$(eval $(call BuildTemplate,account,ACCOUNT,xt_ACCOUNT,ACCOUNT/xt_ACCOUNT,46,+kmod-ipt-compat-xtables))
$(eval $(call BuildTemplate,chaos,CHAOS,xt_CHAOS,xt_CHAOS,47,+kmod-ipt-compat-xtables +kmod-ipt-delude +kmod-ipt-tarpit))
$(eval $(call BuildTemplate,condition,Condition,xt_condition,xt_condition,46,))
$(eval $(call BuildTemplate,delude,DELUDE,xt_DELUDE,xt_DELUDE,46,+kmod-ipt-compat-xtables))
$(eval $(call BuildTemplate,dhcpmac,DHCPMAC,xt_DHCPMAC,xt_DHCPMAC,46,+kmod-ipt-compat-xtables))
-$(eval $(call BuildTemplate,dnetmap,DNETMAP,xt_DNETMAP,xt_DNETMAP,46,+kmod-ipt-compat-xtables))
+$(eval $(call BuildTemplate,dnetmap,DNETMAP,xt_DNETMAP,xt_DNETMAP,46,+kmod-ipt-compat-xtables +kmod-ipt-nat))
$(eval $(call BuildTemplate,fuzzy,fuzzy,xt_fuzzy,xt_fuzzy,46,))
$(eval $(call BuildTemplate,geoip,geoip,xt_geoip,xt_geoip,46,))
$(eval $(call BuildTemplate,iface,iface,xt_iface,xt_iface,46,))
@@ -155,6 +155,6 @@ $(eval $(call BuildTemplate,quota2,quota2,xt_quota2,xt_quota2,46,))
$(eval $(call BuildTemplate,rawnat,RAWNAT,xt_RAWDNAT xt_RAWSNAT,xt_RAWNAT,46,+kmod-ipt-compat-xtables))
$(eval $(call BuildTemplate,steal,STEAL,xt_STEAL,xt_STEAL,46,+kmod-ipt-compat-xtables))
$(eval $(call BuildTemplate,sysrq,SYSRQ,xt_SYSRQ,xt_SYSRQ,46,+kmod-ipt-compat-xtables))
-$(eval $(call BuildTemplate,tarpit,TARPIT,xt_TARPIT,xt_TARPIT,46,+kmod-ipt-compat-xtables))
+$(eval $(call BuildTemplate,tarpit,TARPIT,xt_TARPIT,xt_TARPIT,46,+kmod-ipt-compat-xtables +IPV6:kmod-ipv6))
$(eval $(call BuildPackage,iptaccount))