aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch
diff options
context:
space:
mode:
authorDirk Neukirchen <dirkneukirchen@web.de>2016-09-07 16:16:49 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-09-07 16:16:49 +0200
commitbd1c3202a06eb7f2d1c4b5e1d47e92e9d6622753 (patch)
treeba3177a7fb119226b16459f4abd4d6d4ae1881b1 /package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch
parentfef30a4e67878a1447ac76145fd6addf8e9fecc0 (diff)
downloadmaster-187ad058-bd1c3202a06eb7f2d1c4b5e1d47e92e9d6622753.tar.gz
master-187ad058-bd1c3202a06eb7f2d1c4b5e1d47e92e9d6622753.tar.bz2
master-187ad058-bd1c3202a06eb7f2d1c4b5e1d47e92e9d6622753.zip
xtables-addons: update to 2.11
- fix compilation w. Kernel 4.6 due to hash->shash crypto API - remove a patch integrated upstream - remove unrecognized configure option removed upstream in 2010 commit 40d0345f1ed02de183b13a6ce38847bc1f4ac48e Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
Diffstat (limited to 'package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch')
-rw-r--r--package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch b/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch
index 6a7a099fcc..775ccf657c 100644
--- a/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch
+++ b/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch
@@ -1,11 +1,11 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -44,7 +44,7 @@ regular_CFLAGS="-Wall -Waggregate-return -Wmissing-declarations \
+@@ -44,7 +44,7 @@ regular_CFLAGS="-Wall -Waggregate-return
if test -n "$kbuilddir"; then
AC_MSG_CHECKING([kernel version that we will build against])
-- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')";
-+ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')";
- save_IFS=$IFS;
- IFS='.';
- set x $krel;
+- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')"
++ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion | $AWK -v 'FS=[[^0-9.]]' '{print $1; exit}')"
+ save_IFS="$IFS"
+ IFS='.'
+ set x $krel