aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/wpan-tools/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-04-10 08:30:11 +0000
committerJohn Crispin <blogic@openwrt.org>2015-04-10 08:30:11 +0000
commite45f5fecf6028a1dcf41f26a263a3617c03b09c9 (patch)
tree9add5066fc661e0c4a6986e3af9a4843e4d4f35c /package/network/utils/wpan-tools/Makefile
parentf6124554c78768a63bb60843065477b6393e4ad0 (diff)
downloadmaster-187ad058-e45f5fecf6028a1dcf41f26a263a3617c03b09c9.tar.gz
master-187ad058-e45f5fecf6028a1dcf41f26a263a3617c03b09c9.tar.bz2
master-187ad058-e45f5fecf6028a1dcf41f26a263a3617c03b09c9.zip
wpan-tools: adds wpan-tools utility
This patch adds the wpan-tools (iwpan) utility to OpenWRT build system. This utility required to manage IEE-802.15.4 devices. Signed-off-by: Varka Bhadram <varkab@cdac.in> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45349 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/wpan-tools/Makefile')
-rw-r--r--package/network/utils/wpan-tools/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/package/network/utils/wpan-tools/Makefile b/package/network/utils/wpan-tools/Makefile
new file mode 100644
index 0000000000..87a5fb1461
--- /dev/null
+++ b/package/network/utils/wpan-tools/Makefile
@@ -0,0 +1,36 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=wpan-tools
+PKG_VERSION:=0.4
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://wpan.cakelab.org/releases/
+PKG_MD5SUM:=37575523d1543e06b11295f03a891fa7
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/wpan-tools
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=cfg802154 interface configuration utility
+ URL:=http://wpan.cakelab.org/
+ DEPENDS:= +libnl
+endef
+
+define Build/Configure
+ $(call Build/Configure/Default)
+endef
+
+define Package/wpan-tools/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/iwpan $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,wpan-tools))