aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/uqmi
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-11-25 20:34:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-11-25 20:34:08 +0000
commit380051d86c21814e43813e4e5cb86b343aa81d34 (patch)
tree7d36c8f6fcb666e6ba7089f5ec82dd6f1b14c468 /package/network/utils/uqmi
parent361fddf7b6684e95aa0458865c5dcdff5dbf411c (diff)
downloadmaster-187ad058-380051d86c21814e43813e4e5cb86b343aa81d34.tar.gz
master-187ad058-380051d86c21814e43813e4e5cb86b343aa81d34.tar.bz2
master-187ad058-380051d86c21814e43813e4e5cb86b343aa81d34.zip
uqmi: update to the latest version, also set 802.3 data format via the WDA service
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43381 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/uqmi')
-rw-r--r--package/network/utils/uqmi/Makefile4
-rwxr-xr-xpackage/network/utils/uqmi/files/lib/netifd/proto/qmi.sh1
2 files changed, 3 insertions, 2 deletions
diff --git a/package/network/utils/uqmi/Makefile b/package/network/utils/uqmi/Makefile
index a10e36736e..ed5b057c2c 100644
--- a/package/network/utils/uqmi/Makefile
+++ b/package/network/utils/uqmi/Makefile
@@ -1,13 +1,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uqmi
-PKG_VERSION:=2014-11-19
+PKG_VERSION:=2014-11-25
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/uqmi.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=cef8ce433b5a29b49dfe8700fa7b0ddc2bbb9d20
+PKG_SOURCE_VERSION:=ba48484dac9d39f37eeeb96ad77649e5791ce289
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Matti Laakso <malaakso@elisanet.fi>
# PKG_MIRROR_MD5SUM:=
diff --git a/package/network/utils/uqmi/files/lib/netifd/proto/qmi.sh b/package/network/utils/uqmi/files/lib/netifd/proto/qmi.sh
index bdc5f23928..ae6aa730a6 100755
--- a/package/network/utils/uqmi/files/lib/netifd/proto/qmi.sh
+++ b/package/network/utils/uqmi/files/lib/netifd/proto/qmi.sh
@@ -89,6 +89,7 @@ proto_qmi_setup() {
qmi_disconnect
uqmi -s -d "$device" --set-data-format 802.3
+ uqmi -s -d "$device" --wda-set-data-format 802.3
echo "Waiting for network registration"
while uqmi -s -d "$device" --get-serving-system | grep '"searching"' > /dev/null; do