aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/uqmi/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-05-28 19:45:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-05-28 19:45:20 +0000
commitae88b29aa635a48d4903622384a336232a86a3fe (patch)
tree6d72e67105925fb32927d956c31f58336191934b /package/network/utils/uqmi/Makefile
parentece9382c46e80f0a7a497aecfb61ea6935fc76e5 (diff)
downloadmaster-187ad058-ae88b29aa635a48d4903622384a336232a86a3fe.tar.gz
master-187ad058-ae88b29aa635a48d4903622384a336232a86a3fe.tar.bz2
master-187ad058-ae88b29aa635a48d4903622384a336232a86a3fe.zip
uqmi: Add support for QMI-based mobile broadband modems
Many of the 4G/LTE and 3G modems utilize the QMI-protocol to control the modem. At the moment there is no support for them in OpenWrt. This patch adds support for them in the form of a netifd script and a control utility. Tested with Huawei E398 and ZTE MF820D (which requires a delay of ~30 s before responding to QMI commands). I put myself up as the maintainer, feel free to change this if you desire. Signed-off-by: Matti Laakso <malaakso@elisanet.fi> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40868 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/uqmi/Makefile')
-rw-r--r--package/network/utils/uqmi/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/package/network/utils/uqmi/Makefile b/package/network/utils/uqmi/Makefile
new file mode 100644
index 0000000000..18e0954ad2
--- /dev/null
+++ b/package/network/utils/uqmi/Makefile
@@ -0,0 +1,48 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=uqmi
+PKG_VERSION:=2014-05-27
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://nbd.name/uqmi.git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=d7a56cad6d6ef3c2a5602fc604e31999eb9e78fa
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+PKG_MAINTAINER:=Matti Laakso <malaakso@elisanet.fi>
+# PKG_MIRROR_MD5SUM:=
+# CMAKE_INSTALL:=1
+
+PKG_LICENSE:=GPLv2
+PKG_LICENSE_FILES:=
+
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/uqmi
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=+libubox +libblobmsg-json
+ TITLE:=Control utility for mobile broadband modems
+endef
+
+define Package/uqmi/description
+ uqmi is a command line tool for controlling mobile broadband modems using
+ the QMI-protocol.
+endef
+
+TARGET_CFLAGS += \
+ -I$(STAGING_DIR)/usr/include
+
+CMAKE_OPTIONS += \
+ -DDEBUG=1
+
+define Package/uqmi/install
+ $(INSTALL_DIR) $(1)/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/uqmi $(1)/sbin/
+ $(CP) ./files/* $(1)/
+endef
+
+$(eval $(call BuildPackage,uqmi))