aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/uqmi/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2015-09-11 06:46:40 +0000
committerSteven Barth <steven@midlink.org>2015-09-11 06:46:40 +0000
commit9aa0d300668ac716ee7cd4e9bb84fd812341e029 (patch)
treeab8c55f4b2094322f22f0baf375840e8522a1a84 /package/network/utils/uqmi/Makefile
parent2dcb9df3c90688d65b834c05e81333f2b4552887 (diff)
downloadmaster-187ad058-9aa0d300668ac716ee7cd4e9bb84fd812341e029.tar.gz
master-187ad058-9aa0d300668ac716ee7cd4e9bb84fd812341e029.tar.bz2
master-187ad058-9aa0d300668ac716ee7cd4e9bb84fd812341e029.zip
uqmi: Add proper IPv6 support
Use the new --ip-family option to start both IPv4 and IPv6 sessions by default. Autoconnect can't be used when starting two sessions, so revert back to using the client IDs and packet data handles for handling the network connection. Some modem firmwares do not implement a RA server, therefore by default use outband IP configuration and static addressing. Some other firmwares report bogus IP configuration with the WDS get current settings command. In this case inband configuration with DHCP/RA can be optionally enabled by setting option dhcp to 1. Per 3GPP standard a /64 prefix is served to all clients, which is extended to LAN as specified in RFC 7278. v2: Restrict the IPv6 gateway route source address Signed-off-by: Matti Laakso <malaakso@elisanet.fi> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46843 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/uqmi/Makefile')
-rw-r--r--package/network/utils/uqmi/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/utils/uqmi/Makefile b/package/network/utils/uqmi/Makefile
index 8ca7b85f64..16e7fea0a9 100644
--- a/package/network/utils/uqmi/Makefile
+++ b/package/network/utils/uqmi/Makefile
@@ -1,13 +1,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uqmi
-PKG_VERSION:=2014-12-03
+PKG_VERSION:=2015-08-13
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/uqmi.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=86bcdb8cca652676a78b2df8b5e3fb27a40c60a4
+PKG_SOURCE_VERSION:=8a97586e9445a60e355dea13aa87885ab3dcb277
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Matti Laakso <malaakso@elisanet.fi>
# PKG_MIRROR_MD5SUM:=