aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/umbim/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-08-22 19:02:30 +0000
committerJohn Crispin <blogic@openwrt.org>2014-08-22 19:02:30 +0000
commitc3f7b0fe6db556469a00141da720ed62f0973de2 (patch)
treeadc32edfb4e44663a4108e9b0188414e3c7a9adf /package/network/utils/umbim/Makefile
parent75653caad1127c2279451e3f73c4d130032c316c (diff)
downloadmaster-187ad058-c3f7b0fe6db556469a00141da720ed62f0973de2.tar.gz
master-187ad058-c3f7b0fe6db556469a00141da720ed62f0973de2.tar.bz2
master-187ad058-c3f7b0fe6db556469a00141da720ed62f0973de2.zip
umbim: add netifd proto handler for mbim style lte modems
tested on vodafone k5105 Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42262 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/umbim/Makefile')
-rw-r--r--package/network/utils/umbim/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/package/network/utils/umbim/Makefile b/package/network/utils/umbim/Makefile
new file mode 100644
index 0000000000..a660f88bcb
--- /dev/null
+++ b/package/network/utils/umbim/Makefile
@@ -0,0 +1,45 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=umbim
+PKG_VERSION:=2014-08-22
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://git.openwrt.org/project/umbim.git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=b82f187ab204a56f5ed7cd6d4de64bfdc07a1a74
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
+
+PKG_LICENSE:=GPLv2
+PKG_LICENSE_FILES:=
+
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/umbim
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=+libubox +kmod-usb-net +kmod-usb-net-cdc-mbim
+ TITLE:=Control utility for mobile broadband modems
+endef
+
+define Package/umbim/description
+ umbim is a command line tool for controlling mobile broadband modems using
+ the MBIM-protocol.
+endef
+
+TARGET_CFLAGS += \
+ -I$(STAGING_DIR)/usr/include -ffunction-sections -fdata-sections
+
+TARGET_LDFLAGS += -Wl,--gc-sections
+
+define Package/umbim/install
+ $(INSTALL_DIR) $(1)/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/umbim $(1)/sbin/
+ $(CP) ./files/* $(1)/
+endef
+
+$(eval $(call BuildPackage,umbim))