aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/tcpdump/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-01-22 07:51:15 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-01-22 07:51:15 +0000
commitd7496d57dfb279a90faf8539ce48151b3f2154e2 (patch)
tree84cd9924aa24be8d1114e19f2b9ffd1cd1893c3f /package/network/utils/tcpdump/Makefile
parentfa2240a9bb947c6a5784001538a811b1f051b0cb (diff)
downloadmaster-187ad058-d7496d57dfb279a90faf8539ce48151b3f2154e2.tar.gz
master-187ad058-d7496d57dfb279a90faf8539ce48151b3f2154e2.tar.bz2
master-187ad058-d7496d57dfb279a90faf8539ce48151b3f2154e2.zip
tcpdump: add SLL parsing support to tcpdump-mini, use -ffunction-sections, -fdata-sections and --gc-sections to reduce size
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35288 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/tcpdump/Makefile')
-rw-r--r--package/network/utils/tcpdump/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/network/utils/tcpdump/Makefile b/package/network/utils/tcpdump/Makefile
index df1ee3c31b..b32d25f750 100644
--- a/package/network/utils/tcpdump/Makefile
+++ b/package/network/utils/tcpdump/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tcpdump
PKG_VERSION:=4.2.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.tcpdump.org/release/ \
@@ -54,6 +54,9 @@ CONFIGURE_ARGS += \
--enable-ipv6
endif
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+TARGET_LDFLAGS += -Wl,--gc-sections
+
CONFIGURE_VARS += \
BUILD_CC="$(TARGET_CC)" \
HOSTCC="$(HOSTCC)" \