aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/nftables/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2014-09-17 12:11:06 +0000
committerSteven Barth <steven@midlink.org>2014-09-17 12:11:06 +0000
commit82230772a13343d3feca3a08eb91b649c9eda4e9 (patch)
treea03af3ccb3530ae5029208358d4f7a9eda3e5ddd /package/network/utils/nftables/Makefile
parent73c1110ff325141627549b100012b33700302fa8 (diff)
downloadmaster-187ad058-82230772a13343d3feca3a08eb91b649c9eda4e9.tar.gz
master-187ad058-82230772a13343d3feca3a08eb91b649c9eda4e9.tar.bz2
master-187ad058-82230772a13343d3feca3a08eb91b649c9eda4e9.zip
nftables: introduce experimental nftables
Signed-off-by: Steven Barth <steven@midlink.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42598 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/nftables/Makefile')
-rw-r--r--package/network/utils/nftables/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/package/network/utils/nftables/Makefile b/package/network/utils/nftables/Makefile
new file mode 100644
index 0000000000..8fccc65cc6
--- /dev/null
+++ b/package/network/utils/nftables/Makefile
@@ -0,0 +1,39 @@
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=nftables
+PKG_VERSION:=0.3+2014-09-11
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=git://git.netfilter.org/nftables
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_VERSION:=ae355b89e7b74c28de753bf2878a8e189030ad47
+PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
+
+PKG_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/nftables
+ SECTION:=net
+ CATEGORY:=Network
+ SUBMENU:=Firewall
+ TITLE:=nftables packet filtering userspace utility
+ DEPENDS:=+kmod-nft-core +kmod-nft-nat +libnftnl +libgmp
+ URL:=http://netfilter.org/projects/nftables/
+endef
+
+
+define Package/nftables/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(CP) $(PKG_BUILD_DIR)/src/nft $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,nftables))