aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/linux-atm/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-18 15:35:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-18 15:35:30 +0000
commit9397c477aaa931b6378609ae54364ff82affce7a (patch)
treefc0af16c176962e9ac455e0769cb1d518911e4d0 /package/network/utils/linux-atm/Makefile
parent62a2916d1ecd49104d89afca16d4de978c016dbe (diff)
downloadmaster-187ad058-9397c477aaa931b6378609ae54364ff82affce7a.tar.gz
master-187ad058-9397c477aaa931b6378609ae54364ff82affce7a.tar.bz2
master-187ad058-9397c477aaa931b6378609ae54364ff82affce7a.zip
br2684ctl: resolve a boot time race condition with nas0 bringup by using explicit notification when init is done
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48321 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/linux-atm/Makefile')
-rw-r--r--package/network/utils/linux-atm/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/utils/linux-atm/Makefile b/package/network/utils/linux-atm/Makefile
index 9c6cfec95c..e081428eb0 100644
--- a/package/network/utils/linux-atm/Makefile
+++ b/package/network/utils/linux-atm/Makefile
@@ -178,10 +178,10 @@ define Package/atm-diagnostics/install
endef
define Package/br2684ctl/install
- $(INSTALL_DIR) $(1)/etc/init.d $(1)/etc/hotplug.d/atm
+ $(INSTALL_DIR) $(1)/etc/init.d $(1)/etc/hotplug.d/atm $(1)/usr/sbin $(1)/lib/netifd
+ $(INSTALL_BIN) ./files/br2684-up $(1)/lib/netifd/br2684-up
$(INSTALL_BIN) ./files/br2684ctl $(1)/etc/init.d/
$(INSTALL_DATA) ./files/atm.hotplug $(1)/etc/hotplug.d/atm/00-trigger
- $(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) \
./files/br2684ctl_wrap \
$(PKG_INSTALL_DIR)/usr/sbin/br2684ctl \