aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iwinfo
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-10-29 22:11:57 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-10-29 22:11:57 +0000
commitee9636ff5b0cda7c0927d5677d6c466677c167c7 (patch)
treeda28e59afa3f76df4438ac6aa3d388e0b4604028 /package/network/utils/iwinfo
parent3753ef279f1358778e644d3509f1a242cedfb974 (diff)
downloadmaster-187ad058-ee9636ff5b0cda7c0927d5677d6c466677c167c7.tar.gz
master-187ad058-ee9636ff5b0cda7c0927d5677d6c466677c167c7.tar.bz2
master-187ad058-ee9636ff5b0cda7c0927d5677d6c466677c167c7.zip
iwinfo: properly initialize memory of global nl80211_state, fixes random libnl-tiny assertions when using nl80211_probe() on not supported devices
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34003 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/iwinfo')
-rw-r--r--package/network/utils/iwinfo/Makefile2
-rw-r--r--package/network/utils/iwinfo/src/iwinfo_nl80211.c2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/network/utils/iwinfo/Makefile b/package/network/utils/iwinfo/Makefile
index f05fe4a786..bbef2bdc85 100644
--- a/package/network/utils/iwinfo/Makefile
+++ b/package/network/utils/iwinfo/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libiwinfo
-PKG_RELEASE:=35
+PKG_RELEASE:=36
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
PKG_CONFIG_DEPENDS := \
diff --git a/package/network/utils/iwinfo/src/iwinfo_nl80211.c b/package/network/utils/iwinfo/src/iwinfo_nl80211.c
index 304a18b3ec..763ed61c97 100644
--- a/package/network/utils/iwinfo/src/iwinfo_nl80211.c
+++ b/package/network/utils/iwinfo/src/iwinfo_nl80211.c
@@ -41,6 +41,8 @@ static int nl80211_init(void)
goto err;
}
+ memset(nls, 0, sizeof(*nls));
+
nls->nl_sock = nl_socket_alloc();
if (!nls->nl_sock) {
err = -ENOMEM;