aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iwinfo
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-10-18 11:42:43 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-10-18 11:42:43 +0000
commit533eac9728b417b9ec2aaf3d5505963b243f74ef (patch)
tree383109caa9d4f4ce3ac55c42120fcba2f94bce1e /package/network/utils/iwinfo
parentde3ed2d3d6c5f2ce8b45f25f4076a5720b38c40d (diff)
downloadmaster-187ad058-533eac9728b417b9ec2aaf3d5505963b243f74ef.tar.gz
master-187ad058-533eac9728b417b9ec2aaf3d5505963b243f74ef.tar.bz2
master-187ad058-533eac9728b417b9ec2aaf3d5505963b243f74ef.zip
iwinfo: make 'type' visible in wrapped iwinfo
There are several cases within 'luci' that attempt to access the interface 'type' from within the 'type' specific meta tables; however, 'type' is not currently available there. Replicate the common metadata in the 'type' specific meta tables. Signed-off-by: Nathan Hintz <nlhintz@hotmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38448 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/iwinfo')
-rw-r--r--package/network/utils/iwinfo/Makefile2
-rw-r--r--package/network/utils/iwinfo/src/iwinfo_lua.c4
2 files changed, 5 insertions, 1 deletions
diff --git a/package/network/utils/iwinfo/Makefile b/package/network/utils/iwinfo/Makefile
index aa534112ed..9bebb7a619 100644
--- a/package/network/utils/iwinfo/Makefile
+++ b/package/network/utils/iwinfo/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libiwinfo
-PKG_RELEASE:=46
+PKG_RELEASE:=47
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
PKG_CONFIG_DEPENDS := \
diff --git a/package/network/utils/iwinfo/src/iwinfo_lua.c b/package/network/utils/iwinfo/src/iwinfo_lua.c
index fc4fd4a126..3f1f2061ca 100644
--- a/package/network/utils/iwinfo/src/iwinfo_lua.c
+++ b/package/network/utils/iwinfo/src/iwinfo_lua.c
@@ -862,6 +862,7 @@ LUALIB_API int luaopen_iwinfo(lua_State *L) {
#ifdef USE_WL
luaL_newmetatable(L, IWINFO_WL_META);
+ luaL_register(L, NULL, R_common);
luaL_register(L, NULL, R_wl);
lua_pushvalue(L, -1);
lua_setfield(L, -2, "__index");
@@ -870,6 +871,7 @@ LUALIB_API int luaopen_iwinfo(lua_State *L) {
#ifdef USE_MADWIFI
luaL_newmetatable(L, IWINFO_MADWIFI_META);
+ luaL_register(L, NULL, R_common);
luaL_register(L, NULL, R_madwifi);
lua_pushvalue(L, -1);
lua_setfield(L, -2, "__index");
@@ -878,6 +880,7 @@ LUALIB_API int luaopen_iwinfo(lua_State *L) {
#ifdef USE_NL80211
luaL_newmetatable(L, IWINFO_NL80211_META);
+ luaL_register(L, NULL, R_common);
luaL_register(L, NULL, R_nl80211);
lua_pushvalue(L, -1);
lua_setfield(L, -2, "__index");
@@ -885,6 +888,7 @@ LUALIB_API int luaopen_iwinfo(lua_State *L) {
#endif
luaL_newmetatable(L, IWINFO_WEXT_META);
+ luaL_register(L, NULL, R_common);
luaL_register(L, NULL, R_wext);
lua_pushvalue(L, -1);
lua_setfield(L, -2, "__index");