aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iptables/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-05-21 10:15:10 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-05-21 10:15:10 +0000
commit7962222d782382115b4f46f8569c51f3a4ec3ac2 (patch)
tree9c198545ae4de37b62290e0c2de81b8cd2e0b232 /package/network/utils/iptables/Makefile
parentef948878033307199b43b871b5827c9b6841b0e0 (diff)
downloadmaster-187ad058-7962222d782382115b4f46f8569c51f3a4ec3ac2.tar.gz
master-187ad058-7962222d782382115b4f46f8569c51f3a4ec3ac2.tar.bz2
master-187ad058-7962222d782382115b4f46f8569c51f3a4ec3ac2.zip
iptables: use -ffunction-sections, -fdata-sections and --gc-sections
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36680 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/iptables/Makefile')
-rw-r--r--package/network/utils/iptables/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index fb7aef9a01..a0ea7f7ce0 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=iptables
PKG_VERSION:=1.4.18
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.netfilter.org/projects/iptables/files \
@@ -342,7 +342,11 @@ TARGET_CPPFLAGS := \
TARGET_CFLAGS += \
-I$(PKG_BUILD_DIR)/include \
- -I$(LINUX_DIR)/user_headers/include
+ -I$(LINUX_DIR)/user_headers/include \
+ -ffunction-sections -fdata-sections
+
+TARGET_LDFLAGS += \
+ -Wl,--gc-sections
CONFIGURE_ARGS += \
--enable-shared \