aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iptables/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2013-09-01 17:59:48 +0000
committerSteven Barth <steven@midlink.org>2013-09-01 17:59:48 +0000
commit47c281f29ce3c42425ff91d12c122b5bd26b6790 (patch)
tree4547aa54e0341d59d2a9f8b15bd10091abccd127 /package/network/utils/iptables/Makefile
parent794da7c2356f4e375f4306b6f0f75e0c6df14036 (diff)
downloadmaster-187ad058-47c281f29ce3c42425ff91d12c122b5bd26b6790.tar.gz
master-187ad058-47c281f29ce3c42425ff91d12c122b5bd26b6790.tar.bz2
master-187ad058-47c281f29ce3c42425ff91d12c122b5bd26b6790.zip
netfilter: Add IPv6-NAT support for kernel and ipt
Thanks to Berni, Adam Novak and Sedat Dilek for patches and inspiration git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37866 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/iptables/Makefile')
-rw-r--r--package/network/utils/iptables/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index 879d786e8f..35dda06d9c 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -300,6 +300,17 @@ $(call Package/iptables/Default)
MENU:=1
endef
+
+define Package/ip6tables-mod-nat
+$(call Package/iptables/Default)
+ DEPENDS:=ip6tables +kmod-ipt-nat6
+ TITLE:=IPv6 NAT extensions
+endef
+
+define Package/ip6tables-mod-nat/description
+iptables extensions for IPv6-NAT targets.
+endef
+
define Package/libiptc
$(call Package/iptables/Default)
SECTION:=libs
@@ -447,6 +458,7 @@ $(eval $(call BuildPlugin,iptables-mod-tproxy,$(IPT_TPROXY-m)))
$(eval $(call BuildPlugin,iptables-mod-tee,$(IPT_TEE-m)))
$(eval $(call BuildPlugin,iptables-mod-u32,$(IPT_U32-m)))
$(eval $(call BuildPackage,ip6tables))
+$(eval $(call BuildPlugin,ip6tables-mod-nat,$(IPT_NAT6-m)))
$(eval $(call BuildPackage,libiptc))
$(eval $(call BuildPackage,libip4tc))
$(eval $(call BuildPackage,libip6tc))