aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iproute2/patches
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-07 08:26:41 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-07 08:26:41 +0000
commit7dbe38610428d1a443bf5726dd0a2bbf6a8b4d8c (patch)
tree9df1c570bac0480936538c6e15fffc80cde41388 /package/network/utils/iproute2/patches
parent6b4e0c753f58888403db005511c901a55cd35055 (diff)
downloadmaster-187ad058-7dbe38610428d1a443bf5726dd0a2bbf6a8b4d8c.tar.gz
master-187ad058-7dbe38610428d1a443bf5726dd0a2bbf6a8b4d8c.tar.bz2
master-187ad058-7dbe38610428d1a443bf5726dd0a2bbf6a8b4d8c.zip
[package] iproute2: update to 3.11
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38313 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/iproute2/patches')
-rw-r--r--package/network/utils/iproute2/patches/000-warnings.patch12
-rw-r--r--package/network/utils/iproute2/patches/008-no_netem.patch2
-rw-r--r--package/network/utils/iproute2/patches/110-extra-ccopts.patch4
-rw-r--r--package/network/utils/iproute2/patches/200-add-tc_esfq.patch2
4 files changed, 4 insertions, 16 deletions
diff --git a/package/network/utils/iproute2/patches/000-warnings.patch b/package/network/utils/iproute2/patches/000-warnings.patch
deleted file mode 100644
index 8f07c3896b..0000000000
--- a/package/network/utils/iproute2/patches/000-warnings.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -30,8 +30,7 @@ CC = gcc
- HOSTCC = gcc
- DEFINES += -D_GNU_SOURCE
- CCOPTS = -O2
--WFLAGS := -Wall -Wstrict-prototypes -Werror -Wmissing-prototypes
--WFLAGS += -Wmissing-declarations -Wold-style-definition
-+WFLAGS := -Wall -Wstrict-prototypes
-
- CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)
- YACCFLAGS = -d -t -v
diff --git a/package/network/utils/iproute2/patches/008-no_netem.patch b/package/network/utils/iproute2/patches/008-no_netem.patch
index 78baeadbd1..165ce0c9b9 100644
--- a/package/network/utils/iproute2/patches/008-no_netem.patch
+++ b/package/network/utils/iproute2/patches/008-no_netem.patch
@@ -1,6 +1,6 @@
--- a/Makefile
+++ b/Makefile
-@@ -35,7 +35,7 @@ WFLAGS := -Wall -Wstrict-prototypes
+@@ -36,7 +36,7 @@ WFLAGS += -Wmissing-declarations -Wold-s
CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)
YACCFLAGS = -d -t -v
diff --git a/package/network/utils/iproute2/patches/110-extra-ccopts.patch b/package/network/utils/iproute2/patches/110-extra-ccopts.patch
index 71ec957ad0..4a08757bd9 100644
--- a/package/network/utils/iproute2/patches/110-extra-ccopts.patch
+++ b/package/network/utils/iproute2/patches/110-extra-ccopts.patch
@@ -6,6 +6,6 @@
DEFINES += -D_GNU_SOURCE
-CCOPTS = -O2
+CCOPTS = -O2 $(EXTRA_CCOPTS)
- WFLAGS := -Wall -Wstrict-prototypes
+ WFLAGS := -Wall -Wstrict-prototypes -Wmissing-prototypes
+ WFLAGS += -Wmissing-declarations -Wold-style-definition
- CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)
diff --git a/package/network/utils/iproute2/patches/200-add-tc_esfq.patch b/package/network/utils/iproute2/patches/200-add-tc_esfq.patch
index df5dc017a2..f09b45004f 100644
--- a/package/network/utils/iproute2/patches/200-add-tc_esfq.patch
+++ b/package/network/utils/iproute2/patches/200-add-tc_esfq.patch
@@ -10,7 +10,7 @@
TCMODULES += q_tbf.o
--- a/include/linux/pkt_sched.h
+++ b/include/linux/pkt_sched.h
-@@ -214,6 +214,33 @@ struct tc_sfq_xstats {
+@@ -222,6 +222,33 @@ struct tc_sfq_xstats {
__s32 allot;
};