aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iproute2/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-02 18:12:23 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-02 18:12:23 +0000
commitd23d9cc64dd83bf22efb1dba52844ceb41ccc18c (patch)
tree8ba8dfe88bb0a1d3f7b21d8d4fa8fe2c5d08f396 /package/network/utils/iproute2/Makefile
parent959050826be252a6e8adab38954978158a81a845 (diff)
downloadmaster-187ad058-d23d9cc64dd83bf22efb1dba52844ceb41ccc18c.tar.gz
master-187ad058-d23d9cc64dd83bf22efb1dba52844ceb41ccc18c.tar.bz2
master-187ad058-d23d9cc64dd83bf22efb1dba52844ceb41ccc18c.zip
iproute2: always use -DHAVE_SETNS, since the old uclibc is gone now
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47358 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/iproute2/Makefile')
-rw-r--r--package/network/utils/iproute2/Makefile11
1 files changed, 1 insertions, 10 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index f5b5f4e536..e5015dbdfc 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -78,16 +78,7 @@ define Build/Configure
> $(PKG_BUILD_DIR)/include/SNAPSHOT.h
endef
-ifdef CONFIG_USE_GLIBC
- TARGET_CFLAGS += -DHAVE_SETNS
-endif
-ifdef CONFIG_USE_MUSL
- TARGET_CFLAGS += -DHAVE_SETNS
-endif
-ifdef CONFIG_UCLIBC_USE_VERSION_NG
- TARGET_CFLAGS += -DHAVE_SETNS
-endif
-
+TARGET_CFLAGS += -DHAVE_SETNS
TARGET_CFLAGS += -ffunction-sections -fdata-sections
MAKE_FLAGS += \