aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iproute2/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-19 23:04:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-19 23:04:17 +0000
commit19cb89c9a06e88c40445d8420b7ce086ffed9fc9 (patch)
treeb7e79980d6f7d58739c15f7ea0552a461bce3056 /package/network/utils/iproute2/Makefile
parentd7be7f6241f2faf35833417c03737613879c660d (diff)
downloadmaster-187ad058-19cb89c9a06e88c40445d8420b7ce086ffed9fc9.tar.gz
master-187ad058-19cb89c9a06e88c40445d8420b7ce086ffed9fc9.tar.bz2
master-187ad058-19cb89c9a06e88c40445d8420b7ce086ffed9fc9.zip
iproute2: fix musl build
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42981 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/iproute2/Makefile')
-rw-r--r--package/network/utils/iproute2/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index e2f4b0218a..0b9134e0c9 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -81,6 +81,9 @@ ifdef CONFIG_USE_EGLIBC
TARGET_CFLAGS += -DHAVE_SETNS
endif
endif
+ifdef CONFIG_USE_MUSL
+ TARGET_CFLAGS += -DHAVE_SETNS
+endif
TARGET_CFLAGS += -ffunction-sections -fdata-sections