aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iproute2/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-12-17 15:59:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-12-17 15:59:29 +0000
commit02de71723b1affbd8c2f2ed7ccb6dfd435165abb (patch)
treea15e211ddce882ea3349df64f94dc2623abca9ca /package/network/utils/iproute2/Makefile
parent7683592c57a7b21f2016f149df38d0456be87c44 (diff)
downloadmaster-187ad058-02de71723b1affbd8c2f2ed7ccb6dfd435165abb.tar.gz
master-187ad058-02de71723b1affbd8c2f2ed7ccb6dfd435165abb.tar.bz2
master-187ad058-02de71723b1affbd8c2f2ed7ccb6dfd435165abb.zip
iproute2: reduce .ipk package size from ~100k down to ~60k
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39119 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/iproute2/Makefile')
-rw-r--r--package/network/utils/iproute2/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index dbacd275c6..a44572db8e 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -69,10 +69,15 @@ ifdef CONFIG_USE_EGLIBC
endif
endif
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+
MAKE_FLAGS += \
EXTRA_CCOPTS="$(TARGET_CFLAGS) -I../include -I$(STAGING_DIR)/usr/include/libnl-tiny" \
KERNEL_INCLUDE="$(LINUX_DIR)/include" \
- FPIC="$(FPIC)"
+ SHARED_LIBS="" \
+ LDFLAGS="-Wl,--gc-sections" \
+ IP_CONFIG_TINY=y \
+ FPIC=""
define Build/Compile
+$(MAKE_VARS) $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) $(MAKE_FLAGS)