aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iperf/Makefile
diff options
context:
space:
mode:
authorBert Vermeulen <bert@biot.com>2016-06-21 15:40:45 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-21 15:40:45 +0200
commita115fe6629301745abdd0617ede25db560620e78 (patch)
tree5ecf11653373c0336079019b3133e636278677a8 /package/network/utils/iperf/Makefile
parent9a0c2f5bc3c2d075bec400badb4ad5ed10ddf88a (diff)
downloadmaster-187ad058-a115fe6629301745abdd0617ede25db560620e78.tar.gz
master-187ad058-a115fe6629301745abdd0617ede25db560620e78.tar.bz2
master-187ad058-a115fe6629301745abdd0617ede25db560620e78.zip
iperf: Drop single-threaded variant
Signed-off-by: Bert Vermeulen <bert@biot.com>
Diffstat (limited to 'package/network/utils/iperf/Makefile')
-rw-r--r--package/network/utils/iperf/Makefile40
1 files changed, 4 insertions, 36 deletions
diff --git a/package/network/utils/iperf/Makefile b/package/network/utils/iperf/Makefile
index 48ae43e960..cfd069ff54 100644
--- a/package/network/utils/iperf/Makefile
+++ b/package/network/utils/iperf/Makefile
@@ -24,61 +24,29 @@ PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk
-define Package/iperf/Default
+define Package/iperf
SECTION:=net
CATEGORY:=Network
- DEPENDS:= $(CXX_DEPENDS)
+ DEPENDS:= $(CXX_DEPENDS) +libpthread
TITLE:=Internet Protocol bandwidth measuring tool
URL:=http://sourceforge.net/projects/iperf2/
endef
-define Package/iperf/Default/description
+define Package/iperf/description
Iperf is a modern alternative for measuring TCP and UDP bandwidth
performance, allowing the tuning of various parameters and
characteristics.
endef
-define Package/iperf
-$(call Package/iperf/Default)
- TITLE+= (with single thread support)
- VARIANT:=single
-endef
-
-define Package/iperf/description
-$(call Package/iperf/Default/description)
- This package is built with single thread support.
-endef
-
-define Package/iperf-mt
-$(call Package/iperf/Default)
- DEPENDS+= +libpthread
- TITLE+= (with multithread support)
- VARIANT:=mt
-endef
-
-define Package/iperf-mt/description
-$(call Package/iperf/Default/description)
- This package is built with multithread support.
-endef
-
TARGET_CFLAGS += -D_GNU_SOURCE
CONFIGURE_ARGS += --disable-multicast
-ifeq ($(BUILD_VARIANT),single)
- CONFIGURE_ARGS += --disable-threads
-endif
-
CONFIGURE_VARS += CXXFLAGS="$$$$CXXFLAGS -fno-rtti"
-
-ifeq ($(BUILD_VARIANT),mt)
- CONFIGURE_VARS += LIBS="-lpthread"
-endif
+CONFIGURE_VARS += LIBS="-lpthread"
define Package/iperf/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/iperf $(1)/usr/bin/iperf
endef
-Package/iperf-mt/install = $(Package/iperf/install)
$(eval $(call BuildPackage,iperf))
-$(eval $(call BuildPackage,iperf-mt))