aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/dante/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-12-17 09:29:54 +0000
committerJohn Crispin <blogic@openwrt.org>2015-12-17 09:29:54 +0000
commit61b9031f7b99679ce1a95a7f9f995d47ca1d0515 (patch)
tree385f37a53839d655f2f883f3debf7b66591fc0d2 /package/network/utils/dante/Makefile
parentdcc59ec691373a6464f0290dde0269971b7b7bc9 (diff)
downloadmaster-187ad058-61b9031f7b99679ce1a95a7f9f995d47ca1d0515.tar.gz
master-187ad058-61b9031f7b99679ce1a95a7f9f995d47ca1d0515.tar.bz2
master-187ad058-61b9031f7b99679ce1a95a7f9f995d47ca1d0515.zip
dante: update to 1.4.1
- 1.4.x has IPv6 support - set C std explicitly due to gcc 5 changes/old code style of dante - disable pam via configure vars since detection of without pam option is broken (-lpam gets linked in if available) - remove and refresh patches only compile tested Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47926 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/dante/Makefile')
-rw-r--r--package/network/utils/dante/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/network/utils/dante/Makefile b/package/network/utils/dante/Makefile
index f10dd86c1b..b49ae7291c 100644
--- a/package/network/utils/dante/Makefile
+++ b/package/network/utils/dante/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=dante
-PKG_VERSION:=1.2.2
+PKG_VERSION:=1.4.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -23,14 +23,15 @@ PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
-TARGET_CFLAGS += -D_GNU_SOURCE
+TARGET_CFLAGS += -D_GNU_SOURCE -std=gnu89
+
CONFIGURE_ARGS += \
--without-upnp \
--without-pam \
--disable-libwrap
CONFIGURE_VARS += \
- CC="$(TARGET_CC) $(TARGET_CFLAGS)"
+ ac_cv_search_pam_start=""
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include