aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/comgt
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-10-08 08:00:55 +0000
committerJohn Crispin <blogic@openwrt.org>2014-10-08 08:00:55 +0000
commitf93a2e4c7ed6c1e4f755ce47d68997022ea0010b (patch)
treefb132c6550d304e3138901054593429dbaf13888 /package/network/utils/comgt
parentf4dd6b28f2745d9f7136b546ca7187a547e1a998 (diff)
downloadmaster-187ad058-f93a2e4c7ed6c1e4f755ce47d68997022ea0010b.tar.gz
master-187ad058-f93a2e4c7ed6c1e4f755ce47d68997022ea0010b.tar.bz2
master-187ad058-f93a2e4c7ed6c1e4f755ce47d68997022ea0010b.zip
comgt: split directip support into its own package
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42836 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/comgt')
-rw-r--r--package/network/utils/comgt/Makefile22
1 files changed, 19 insertions, 3 deletions
diff --git a/package/network/utils/comgt/Makefile b/package/network/utils/comgt/Makefile
index 254670693a..21dda8bd56 100644
--- a/package/network/utils/comgt/Makefile
+++ b/package/network/utils/comgt/Makefile
@@ -22,14 +22,24 @@ PKG_CHECK_FORMAT_SECURITY:=0
include $(INCLUDE_DIR)/package.mk
-define Package/comgt
+define Package/comgt/Default
SECTION:=utils
CATEGORY:=Utilities
+endef
+
+define Package/comgt
+$(call Package/comgt/Default)
TITLE:=Option/Vodafone 3G/GPRS control tool
DEPENDS:=+chat
URL:=http://www.pharscape.org/comgt.html
endef
+define Package/comgt-directip
+$(call Package/comgt/Default)
+ TITLE:=Sierra Wireless Direct-IP support
+ DEPENDS:=+comgt +kmod-usb-serial +kmod-usb-serial-sierrawireless +kmod-usb-net +kmod-usb-net-sierrawireless
+endef
+
define Package/comgt/description
comgt is a scripting language interpreter useful for establishing
communications on serial lines and through PCMCIA modems as well as GPRS
@@ -59,13 +69,19 @@ define Package/comgt/install
$(INSTALL_DATA) ./files/getcarrier.gcom $(1)/etc/gcom/getcarrier.gcom
$(INSTALL_DATA) ./files/getcnum.gcom $(1)/etc/gcom/getcnum.gcom
$(INSTALL_DATA) ./files/getimsi.gcom $(1)/etc/gcom/getimsi.gcom
- $(INSTALL_DATA) ./files/directip.gcom $(1)/etc/gcom/directip.gcom
- $(INSTALL_DATA) ./files/directip-stop.gcom $(1)/etc/gcom/directip-stop.gcom
$(INSTALL_DIR) $(1)/etc/hotplug.d/tty
$(INSTALL_DATA) ./files/3g.usb $(1)/etc/hotplug.d/tty/30-3g
$(INSTALL_DIR) $(1)/lib/netifd/proto
$(INSTALL_BIN) ./files/3g.sh $(1)/lib/netifd/proto/3g.sh
+endef
+
+define Package/comgt-directip/install
+ $(INSTALL_DIR) $(1)/etc/gcom
+ $(INSTALL_DATA) ./files/directip.gcom $(1)/etc/gcom/directip.gcom
+ $(INSTALL_DATA) ./files/directip-stop.gcom $(1)/etc/gcom/directip-stop.gcom
+ $(INSTALL_DIR) $(1)/lib/netifd/proto
$(INSTALL_BIN) ./files/directip.sh $(1)/lib/netifd/proto/directip.sh
endef
$(eval $(call BuildPackage,comgt))
+$(eval $(call BuildPackage,comgt-directip))