aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/comgt
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-10-20 10:00:02 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-10-20 10:00:02 +0000
commitcbc5f498cdffbf7ba47549b4cebd9ce7838c59c6 (patch)
treeaa9870462f7176044377365f68b4eb8fb2faeeab /package/network/utils/comgt
parenta9160b7360f2624e43b99f3cc25f11b82bd2fc09 (diff)
downloadmaster-187ad058-cbc5f498cdffbf7ba47549b4cebd9ce7838c59c6.tar.gz
master-187ad058-cbc5f498cdffbf7ba47549b4cebd9ce7838c59c6.tar.bz2
master-187ad058-cbc5f498cdffbf7ba47549b4cebd9ce7838c59c6.zip
[comgt]: fix compile against musl
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43000 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/comgt')
-rw-r--r--package/network/utils/comgt/Makefile4
-rw-r--r--package/network/utils/comgt/patches/002-termios.patch29
2 files changed, 31 insertions, 2 deletions
diff --git a/package/network/utils/comgt/Makefile b/package/network/utils/comgt/Makefile
index 5fccd947e6..2edb9a0f3c 100644
--- a/package/network/utils/comgt/Makefile
+++ b/package/network/utils/comgt/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=comgt
PKG_VERSION:=0.32
-PKG_RELEASE:=23
+PKG_RELEASE:=24
PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
PKG_SOURCE_URL:=@SF/comgt
diff --git a/package/network/utils/comgt/patches/002-termios.patch b/package/network/utils/comgt/patches/002-termios.patch
new file mode 100644
index 0000000000..3649f3cf09
--- /dev/null
+++ b/package/network/utils/comgt/patches/002-termios.patch
@@ -0,0 +1,29 @@
+--- a/comgt.c
++++ b/comgt.c
+@@ -30,7 +30,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <signal.h>
+-#include <termio.h>
++#include <termios.h>
+ #include <fcntl.h>
+ #include <unistd.h>
+ #include <string.h>
+@@ -81,7 +81,7 @@ char token[MAXTOKEN]; /* For gettoken(
+ char scriptfile[MAXPATH]; /* Script file name */
+ char scriptfilepath[MAXPATH]; /* temp storage for full path */
+ BOOL verbose=0; /* Log actions */
+-struct termio cons, stbuf, svbuf; /* termios: svbuf=before, stbuf=while */
++struct termios cons, stbuf, svbuf; /* termios: svbuf=before, stbuf=while */
+ int comfd=0; /* Communication file descriptor. Defaults to stdin. */
+ char msg[STRINGL]; /* Massage messages here */
+ int preturn,returns[MAXGOSUBS];
+@@ -926,7 +926,7 @@ void setcom(void) {
+ }
+
+ void doset(void) {
+- struct termio console;
++ struct termios console;
+ int a,b;
+ gettoken();
+ if(strcmp(token,"echo")==0) {