aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/comgt/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-10-08 08:01:20 +0000
committerJohn Crispin <blogic@openwrt.org>2014-10-08 08:01:20 +0000
commit98e716884d9421af03c89637613498b87c69617a (patch)
tree8675dcb267039fb6b1351ffc59ef910f444a3ca3 /package/network/utils/comgt/Makefile
parentf93a2e4c7ed6c1e4f755ce47d68997022ea0010b (diff)
downloadmaster-187ad058-98e716884d9421af03c89637613498b87c69617a.tar.gz
master-187ad058-98e716884d9421af03c89637613498b87c69617a.tar.bz2
master-187ad058-98e716884d9421af03c89637613498b87c69617a.zip
wwan: add a generic 3g/4g proto
this proto handler will detect which of 3g, qmi, mbim, ncm or directip you need for a stick and setup uci automagically Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42837 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/utils/comgt/Makefile')
-rw-r--r--package/network/utils/comgt/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/network/utils/comgt/Makefile b/package/network/utils/comgt/Makefile
index 21dda8bd56..11a1a49139 100644
--- a/package/network/utils/comgt/Makefile
+++ b/package/network/utils/comgt/Makefile
@@ -73,6 +73,9 @@ define Package/comgt/install
$(INSTALL_DATA) ./files/3g.usb $(1)/etc/hotplug.d/tty/30-3g
$(INSTALL_DIR) $(1)/lib/netifd/proto
$(INSTALL_BIN) ./files/3g.sh $(1)/lib/netifd/proto/3g.sh
+ $(INSTALL_BIN) ./files/directip.sh $(1)/lib/netifd/proto/directip.sh
+ $(INSTALL_DIR) $(1)/lib/network/wwan/
+ $(INSTALL_DATA) ./files/data/* $(1)/lib/network/wwan/
endef
define Package/comgt-directip/install