aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/uhttpd
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-25 17:59:08 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-25 17:59:08 +0000
commitdfa9a409c99bf7f7fb88e371d54163cc92c540d5 (patch)
tree3c5b7a2cc3fcfdd2ae8cb1c8a791cded8b32fb44 /package/network/services/uhttpd
parent60fade712548ed1d024b474b95833f9fe680337c (diff)
downloadmaster-187ad058-dfa9a409c99bf7f7fb88e371d54163cc92c540d5.tar.gz
master-187ad058-dfa9a409c99bf7f7fb88e371d54163cc92c540d5.tar.bz2
master-187ad058-dfa9a409c99bf7f7fb88e371d54163cc92c540d5.zip
uhttpd: fix time_t type mismatch on 32bit systems
The previous update introducing LFS support unconditionally changed the sprintf() pattern used to print the file modification time to use PRIx64. Explicitely convert the st_mtime member of the stat struct to uint64_t in order to avoid type mismatch errors when building for non-64bit targets. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44138 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services/uhttpd')
-rw-r--r--package/network/services/uhttpd/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index 9cd28e25d0..1bb0084392 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_VERSION:=2015-01-25
+PKG_VERSION:=2015-01-25.1
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/uhttpd2.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=7352ec423fb99a7970b0765287503abee05a56cd
+PKG_SOURCE_VERSION:=d404cd06b657cdcd97555362abec7966e339fd6d
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
PKG_LICENSE:=ISC