aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/uhttpd
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-25 17:23:26 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-25 17:23:26 +0000
commitcfc5c0c8b42d60ccad56179445bed71609a8c5c9 (patch)
tree7a7104b7e2a02a4464fe3ba45862fc67a7437ea0 /package/network/services/uhttpd
parent59dbb6ac93ce39fbe712eee45b1a46ba715aad7a (diff)
downloadmaster-187ad058-cfc5c0c8b42d60ccad56179445bed71609a8c5c9.tar.gz
master-187ad058-cfc5c0c8b42d60ccad56179445bed71609a8c5c9.tar.bz2
master-187ad058-cfc5c0c8b42d60ccad56179445bed71609a8c5c9.zip
uhttpd: fix crash with enabled relro, memory leak in dirlists and lfs
* Fix the ubus plugin to not make its uhttpd_plugin entry symbol constant as uhttpd needs to modify its list_head member * Make sure that uhttpd supports large files by using 64bit ints where appropriate and by passing _FILE_OFFSET_BITS=64 to the build * Plug a possible memleak in the directory listing code Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44135 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services/uhttpd')
-rw-r--r--package/network/services/uhttpd/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index e6e6753a68..9cd28e25d0 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2010-2014 Jo-Philipp Wich <jow@openwrt.org>
+# Copyright (C) 2010-2015 Jo-Philipp Wich <jow@openwrt.org>
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_VERSION:=2014-10-27
+PKG_VERSION:=2015-01-25
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/uhttpd2.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=fd8e5e379c23c5fbcec3e76894b839233df09067
+PKG_SOURCE_VERSION:=7352ec423fb99a7970b0765287503abee05a56cd
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
PKG_LICENSE:=ISC