aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/uhttpd
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-11-11 19:14:01 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-11-11 19:14:01 +0000
commit781c17117a3a6c40d9e39dc2cb016e2a80aeee4e (patch)
tree733a3c5e74d3180f4edea2b621e218a1cd7560fa /package/network/services/uhttpd
parent9475a183be61dd765f0301f3eae2a3bc7cd0efe9 (diff)
downloadmaster-187ad058-781c17117a3a6c40d9e39dc2cb016e2a80aeee4e.tar.gz
master-187ad058-781c17117a3a6c40d9e39dc2cb016e2a80aeee4e.tar.bz2
master-187ad058-781c17117a3a6c40d9e39dc2cb016e2a80aeee4e.zip
uhttpd: return after processing -d switch, only set ubus prefix if not already defined
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38743 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services/uhttpd')
-rw-r--r--package/network/services/uhttpd/Makefile4
-rw-r--r--package/network/services/uhttpd/files/ubus.default8
2 files changed, 8 insertions, 4 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index be1a1e27f1..46a39a1718 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_VERSION:=2013-09-13
+PKG_VERSION:=2013-11-11
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/uhttpd2.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=8eb20e0aad7412468975b2c9ce7e374ea3084e42
+PKG_SOURCE_VERSION:=881d6102cf1f7bc6b54ab395c5e4addbfe1ed34c
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
diff --git a/package/network/services/uhttpd/files/ubus.default b/package/network/services/uhttpd/files/ubus.default
index ba6c289f84..397456db6a 100644
--- a/package/network/services/uhttpd/files/ubus.default
+++ b/package/network/services/uhttpd/files/ubus.default
@@ -1,2 +1,6 @@
-uci set uhttpd.main.ubus_prefix=/ubus
-uci commit uhttpd
+#!/bin/sh
+
+if [ -z "$(uci -q get uhttpd.main.ubus_prefix)" ]; then
+ uci set uhttpd.main.ubus_prefix=/ubus
+ uci commit uhttpd
+fi