aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/mdns/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-03-26 10:58:44 +0000
committerJohn Crispin <blogic@openwrt.org>2015-03-26 10:58:44 +0000
commit438c19fc32b7d1e9b2cb76c77c3d9dddac753e27 (patch)
tree8929a2b38d42fc9df04a5631fc6ba9660da062e6 /package/network/services/mdns/Makefile
parent324ca9971e7039cd03f206c2afe17a81672f11e8 (diff)
downloadmaster-187ad058-438c19fc32b7d1e9b2cb76c77c3d9dddac753e27.tar.gz
master-187ad058-438c19fc32b7d1e9b2cb76c77c3d9dddac753e27.tar.bz2
master-187ad058-438c19fc32b7d1e9b2cb76c77c3d9dddac753e27.zip
mdns: add jail and seccomp support
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45012 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services/mdns/Makefile')
-rw-r--r--package/network/services/mdns/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/network/services/mdns/Makefile b/package/network/services/mdns/Makefile
index 690f54770a..a731400206 100644
--- a/package/network/services/mdns/Makefile
+++ b/package/network/services/mdns/Makefile
@@ -20,6 +20,7 @@ PKG_SOURCE_VERSION:=a5560f88bb2cddeef0ef11a12e7822b9c19a75a5
PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
PKG_LICENSE:=LGPL-2.1
+include $(INCLUDE_DIR)/package-seccomp.mk
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
@@ -37,6 +38,7 @@ define Package/mdns/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/mdns $(1)/usr/sbin/
$(INSTALL_BIN) ./files/mdns.init $(1)/etc/init.d/mdns
$(INSTALL_CONF) ./files/mdns.config $(1)/etc/config/mdns
+ $(call InstallSeccomp,$(1),./files/mdns.json)
endef
$(eval $(call BuildPackage,mdns))