aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-05-06 00:59:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-05-06 00:59:36 +0000
commitb045945a42732c4c7112cca6a87171bca2e3bdd5 (patch)
tree43169a3c3f4a6d66a37710381c15145ffc5d0c2f /package/network/services/hostapd
parentbc76393de3b8ad0edb881db058c63b451ea9075b (diff)
downloadmaster-187ad058-b045945a42732c4c7112cca6a87171bca2e3bdd5.tar.gz
master-187ad058-b045945a42732c4c7112cca6a87171bca2e3bdd5.tar.bz2
master-187ad058-b045945a42732c4c7112cca6a87171bca2e3bdd5.zip
hostapd: enable 802.11w only for the full variants
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45616 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services/hostapd')
-rw-r--r--package/network/services/hostapd/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index b8acee0632..3dff7b4852 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -68,9 +68,12 @@ DRIVER_MAKEOPTS= \
CONFIG_DRIVER_NL80211=$(CONFIG_PACKAGE_kmod-cfg80211) \
CONFIG_DRIVER_HOSTAP=$(CONFIG_PACKAGE_kmod-hostap) \
CONFIG_IEEE80211N=$(HOSTAPD_IEEE80211N) \
- CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k) \
CONFIG_DRIVER_WEXT=$(CONFIG_DRIVER_WEXT_SUPPORT) \
+ifeq ($(LOCAL_VARIANT),full)
+ CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k)
+endif
+
ifneq ($(LOCAL_TYPE),hostapd)
ifdef CONFIG_WPA_SUPPLICANT_OPENSSL
ifeq ($(LOCAL_VARIANT),full)