aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-08-27 12:43:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-08-27 12:43:22 +0000
commit673653cfc78988e1a7c3354934fa18381c4203a2 (patch)
tree15163ce52a7cff56562764dc2fa7356445f45063 /package/network/services/hostapd
parente53ef786554097f42856e9ade31fd9f0845177c2 (diff)
downloadmaster-187ad058-673653cfc78988e1a7c3354934fa18381c4203a2.tar.gz
master-187ad058-673653cfc78988e1a7c3354934fa18381c4203a2.tar.bz2
master-187ad058-673653cfc78988e1a7c3354934fa18381c4203a2.zip
hostapd: properly enable 802.11w support
Add CONFIG_IEEE80211W variable to DRIVER_MAKEOPTS so that 802.11w support is properly compiled in full variant. This fixes #20179 Signed-off-by: Janusz Dziemidowicz <rraptorr@nails.eu.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46737 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services/hostapd')
-rw-r--r--package/network/services/hostapd/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 3dff7b4852..c16cb11294 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -71,7 +71,7 @@ DRIVER_MAKEOPTS= \
CONFIG_DRIVER_WEXT=$(CONFIG_DRIVER_WEXT_SUPPORT) \
ifeq ($(LOCAL_VARIANT),full)
- CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k)
+ DRIVER_MAKEOPTS += CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k)
endif
ifneq ($(LOCAL_TYPE),hostapd)