aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-27 14:55:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-27 14:55:01 +0000
commit646588cf5c294286dc0d47be3ec426a7681c0d4d (patch)
treeb7b041fbbf5154b1533c9bd766fbb189e6b4cf08 /package/network/services/hostapd
parentdbba30940dc0685c42da78341dd000c9495ae4f5 (diff)
downloadmaster-187ad058-646588cf5c294286dc0d47be3ec426a7681c0d4d.tar.gz
master-187ad058-646588cf5c294286dc0d47be3ec426a7681c0d4d.tar.bz2
master-187ad058-646588cf5c294286dc0d47be3ec426a7681c0d4d.zip
hostapd: fix compile errors with nl80211 disabled (#19325)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45063 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services/hostapd')
-rw-r--r--package/network/services/hostapd/Makefile1
-rw-r--r--package/network/services/hostapd/files/hostapd-full.config2
-rw-r--r--package/network/services/hostapd/files/hostapd-mini.config2
-rw-r--r--package/network/services/hostapd/patches/600-ubus_support.patch6
4 files changed, 6 insertions, 5 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 7cbbe8d5d5..9a5b29b4d6 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -64,6 +64,7 @@ ifneq ($(CONFIG_DRIVER_11N_SUPPORT),)
endif
DRIVER_MAKEOPTS= \
+ CONFIG_ACS=$(CONFIG_PACKAGE_kmod-cfg80211) \
CONFIG_DRIVER_NL80211=$(CONFIG_PACKAGE_kmod-cfg80211) \
CONFIG_DRIVER_HOSTAP=$(CONFIG_PACKAGE_kmod-hostap) \
CONFIG_IEEE80211N=$(HOSTAPD_IEEE80211N) \
diff --git a/package/network/services/hostapd/files/hostapd-full.config b/package/network/services/hostapd/files/hostapd-full.config
index b9b2d8d8b3..f1b2655cfc 100644
--- a/package/network/services/hostapd/files/hostapd-full.config
+++ b/package/network/services/hostapd/files/hostapd-full.config
@@ -163,6 +163,4 @@ CONFIG_NO_DUMP_STATE=y
CONFIG_WPS=y
CONFIG_FULL_DYNAMIC_VLAN=y
-CONFIG_ACS=y
-
CONFIG_UBUS=y
diff --git a/package/network/services/hostapd/files/hostapd-mini.config b/package/network/services/hostapd/files/hostapd-mini.config
index 3924522123..118d97cb3a 100644
--- a/package/network/services/hostapd/files/hostapd-mini.config
+++ b/package/network/services/hostapd/files/hostapd-mini.config
@@ -156,6 +156,4 @@ CONFIG_TLS=internal
CONFIG_NO_RANDOM_POOL=y
CONFIG_NO_DUMP_STATE=y
-CONFIG_ACS=y
-
CONFIG_UBUS=y
diff --git a/package/network/services/hostapd/patches/600-ubus_support.patch b/package/network/services/hostapd/patches/600-ubus_support.patch
index 98acf19b5b..5375c935bd 100644
--- a/package/network/services/hostapd/patches/600-ubus_support.patch
+++ b/package/network/services/hostapd/patches/600-ubus_support.patch
@@ -41,7 +41,7 @@
HAPD_IFACE_DISABLED,
--- /dev/null
+++ b/src/ap/ubus.c
-@@ -0,0 +1,490 @@
+@@ -0,0 +1,494 @@
+/*
+ * hostapd / ubus support
+ * Copyright (c) 2013, Felix Fietkau <nbd@openwrt.org>
@@ -358,6 +358,7 @@
+ [CSA_BCN_COUNT] = { "bcn_count", BLOBMSG_TYPE_INT32 },
+};
+
++#ifdef NEED_AP_MLME
+static int
+hostapd_switch_chan(struct ubus_context *ctx, struct ubus_object *obj,
+ struct ubus_request_data *req, const char *method,
@@ -381,6 +382,7 @@
+ return UBUS_STATUS_NOT_SUPPORTED;
+ return UBUS_STATUS_OK;
+}
++#endif
+
+enum {
+ VENDOR_ELEMENTS,
@@ -423,7 +425,9 @@
+ UBUS_METHOD_NOARG("list_bans", hostapd_bss_list_bans),
+ UBUS_METHOD_NOARG("wps_start", hostapd_bss_wps_start),
+ UBUS_METHOD_NOARG("wps_cancel", hostapd_bss_wps_cancel),
++#ifdef NEED_AP_MLME
+ UBUS_METHOD("switch_chan", hostapd_switch_chan, csa_policy),
++#endif
+ UBUS_METHOD("set_vendor_elements", hostapd_vendor_elements, ve_policy),
+};
+