aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-11-23 14:16:47 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-11-23 14:16:47 +0000
commit92cccc6bf594ffe2c6beead1b666acb713ea88e2 (patch)
treece79d13ca7acfa7f0c6c8cf9eb1dd38515308980 /package/network/services/hostapd/Makefile
parent57c8c1da72ba3b5110d50db36f7dec4155496e52 (diff)
downloadmaster-187ad058-92cccc6bf594ffe2c6beead1b666acb713ea88e2.tar.gz
master-187ad058-92cccc6bf594ffe2c6beead1b666acb713ea88e2.tar.bz2
master-187ad058-92cccc6bf594ffe2c6beead1b666acb713ea88e2.zip
hostapd: fix build error on some variants with CONFIG_WPA_RFKILL_SUPPORT=y (#17765)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43345 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services/hostapd/Makefile')
-rw-r--r--package/network/services/hostapd/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 838ef39aba..19d536ecc0 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -71,7 +71,6 @@ DRIVER_MAKEOPTS= \
CONFIG_IEEE80211N=$(HOSTAPD_IEEE80211N) \
CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k) \
CONFIG_DRIVER_WEXT=$(CONFIG_DRIVER_WEXT_SUPPORT) \
- $(if $(CONFIG_WPA_RFKILL_SUPPORT),NEED_RFKILL=y)
ifneq ($(LOCAL_TYPE),hostapd)
ifdef CONFIG_WPA_SUPPLICANT_OPENSSL
@@ -83,6 +82,9 @@ ifneq ($(LOCAL_TYPE),hostapd)
ifdef CONFIG_WPA_SUPPLICANT_NO_TIMESTAMP_CHECK
TARGET_CFLAGS += -DNO_TIMESTAMP_CHECK
endif
+ ifdef CONFIG_WPA_RFKILL_SUPPORT)
+ DRIVER_MAKEOPTS += NEED_RFKILL=y
+ endif
DRIVER_MAKEOPTS += \
CONFIG_DRIVER_ROBOSWITCH=$(CONFIG_PACKAGE_kmod-switch)
endif