aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-03-17 20:47:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-03-17 20:47:18 +0000
commit77a736a2b6a48ae5c915af94057e55e257859cc8 (patch)
tree6c3a0b967a163f3f3bc0cd3d1dad3f87772c1b5b /package/network/services/hostapd/Makefile
parent4f925948b1ed627edc6ab9c071f6c34d4773a680 (diff)
downloadmaster-187ad058-77a736a2b6a48ae5c915af94057e55e257859cc8.tar.gz
master-187ad058-77a736a2b6a48ae5c915af94057e55e257859cc8.tar.bz2
master-187ad058-77a736a2b6a48ae5c915af94057e55e257859cc8.zip
hostapd: initial prototype of an ubus binding
Supports listing, removing and banning clients, and hooking into probe/assoc/auth requests via object subscribe. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36081 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services/hostapd/Makefile')
-rw-r--r--package/network/services/hostapd/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 16db2d8e23..0c44a8b08d 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -93,7 +93,7 @@ define Package/hostapd/Default
CATEGORY:=Network
TITLE:=IEEE 802.1x Authenticator
URL:=http://hostap.epitest.fi/
- DEPENDS:=$(DRV_DEPENDS)
+ DEPENDS:=$(DRV_DEPENDS) +libubus
endef
define Package/hostapd
@@ -138,7 +138,7 @@ endef
define Package/wpad
$(call Package/wpad/Default)
TITLE+= (full)
- DEPENDS:=$(DRV_DEPENDS) +WPA_SUPPLICANT_OPENSSL:libopenssl
+ DEPENDS:=$(DRV_DEPENDS) +WPA_SUPPLICANT_OPENSSL:libopenssl +libubus
VARIANT:=wpad-full
endef
@@ -150,7 +150,7 @@ endef
define Package/wpad-mini
$(call Package/wpad/Default)
TITLE+= (WPA-PSK only)
- DEPENDS:=$(DRV_DEPENDS)
+ DEPENDS:=$(DRV_DEPENDS) +libubus
VARIANT:=wpad-mini
endef
@@ -225,6 +225,7 @@ TARGET_CPPFLAGS := \
TARGET_CFLAGS += -ffunction-sections -fdata-sections
TARGET_LDFLAGS += -Wl,--gc-sections
+TARGET_LDFLAGS += -lubox -lubus
ifdef CONFIG_PACKAGE_kmod-mac80211
TARGET_LDFLAGS += -lm -lnl-tiny