aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/dnsmasq/patches
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-01-05 13:03:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-01-05 13:03:48 +0000
commitafdb4caec639b2e5fc2b8bf3b5dab49b3ce42b98 (patch)
tree2672e97f4ba6402b2d8db55f00b5b7a6caa7b90c /package/network/services/dnsmasq/patches
parentcc0700a38fe634baa366025dc21393d0d903934e (diff)
downloadmaster-187ad058-afdb4caec639b2e5fc2b8bf3b5dab49b3ce42b98.tar.gz
master-187ad058-afdb4caec639b2e5fc2b8bf3b5dab49b3ce42b98.tar.bz2
master-187ad058-afdb4caec639b2e5fc2b8bf3b5dab49b3ce42b98.zip
dnsmasq: fix dependency problems of the dnsmasq-full variant.
This patch tries to - Let the DHCPv6 feature depend on CONFIG_IPV6. - Conditionally select libnettle, kmod-ipv6, kmod-ipt-ipset only if the corresponding features are enabled. - Install `trust-anchors.conf` only if DNSSEC is selected. - Add PKG_CONFIG_DEPENDS for the configurable options. - Add a patch to let the Makefile of dnsmasq be aware of changes in COPTS variable. Big thanks goes to Frank Schäfer <fschaefer.oss@googlemail.com> for providing necessary information on connections and dependency relations between these CONFIGs and packages. Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43851 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services/dnsmasq/patches')
-rw-r--r--package/network/services/dnsmasq/patches/200-let-makefile-be-aware-of-config-changes.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/package/network/services/dnsmasq/patches/200-let-makefile-be-aware-of-config-changes.patch b/package/network/services/dnsmasq/patches/200-let-makefile-be-aware-of-config-changes.patch
new file mode 100644
index 0000000000..663f0e9ed3
--- /dev/null
+++ b/package/network/services/dnsmasq/patches/200-let-makefile-be-aware-of-config-changes.patch
@@ -0,0 +1,42 @@
+Index: dnsmasq-2.72/Makefile
+===================================================================
+--- dnsmasq-2.72.orig/Makefile 2014-12-30 19:46:10.484921940 +0800
++++ dnsmasq-2.72/Makefile 2014-12-30 19:56:39.712926794 +0800
+@@ -74,6 +74,10 @@
+ hdrs = dnsmasq.h config.h dhcp-protocol.h dhcp6-protocol.h \
+ dns-protocol.h radv-protocol.h ip6addr.h
+
++COPT_CONF = $(top)/.copt_$(shell $(CC) -DDNSMASQ_COMPILE_OPTS $(COPTS) -E $(top)/$(SRC)/config.h | \
++ ( md5sum 2>/dev/null || md5 ) | cut -f 1 -d ' ')
++COPT_CONF_WILD = $(top)/.copt_*
++
+ all : $(BUILDDIR)
+ @cd $(BUILDDIR) && $(MAKE) \
+ top="$(top)" \
+@@ -83,7 +87,7 @@
+
+ mostly_clean :
+ rm -f $(BUILDDIR)/*.mo $(BUILDDIR)/*.pot
+- rm -f $(BUILDDIR)/.configured $(BUILDDIR)/*.o $(BUILDDIR)/dnsmasq.a $(BUILDDIR)/dnsmasq
++ rm -f $(BUILDDIR)/$(COPT_CONF_WILD) $(BUILDDIR)/*.o $(BUILDDIR)/dnsmasq.a $(BUILDDIR)/dnsmasq
+
+ clean : mostly_clean
+ rm -f $(BUILDDIR)/dnsmasq_baseline
+@@ -139,7 +143,7 @@
+
+ # rules below are targets in recusive makes with cwd=$(BUILDDIR)
+
+-.configured: $(hdrs)
++$(COPT_CONF): $(hdrs)
+ @rm -f *.o
+ @touch $@
+
+@@ -149,7 +153,7 @@
+ .c.o:
+ $(CC) $(CFLAGS) $(COPTS) $(i18n) $(build_cflags) $(RPM_OPT_FLAGS) -c $<
+
+-dnsmasq : .configured $(hdrs) $(objs)
++dnsmasq : $(COPT_CONF) $(hdrs) $(objs)
+ $(CC) $(LDFLAGS) -o $@ $(objs) $(build_libs) $(LIBS)
+
+ dnsmasq.pot : $(objs:.o=.c) $(hdrs)