aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/authsae
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-07-26 10:02:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-07-26 10:02:55 +0000
commita22105f7ce571a13cdef869ff29c1df350b4780c (patch)
treef91e86481ff0d78051377eaa416cf599db83f63a /package/network/services/authsae
parent10bcb242857e8442ef777e8168485c118fc79eea (diff)
downloadmaster-187ad058-a22105f7ce571a13cdef869ff29c1df350b4780c.tar.gz
master-187ad058-a22105f7ce571a13cdef869ff29c1df350b4780c.tar.bz2
master-187ad058-a22105f7ce571a13cdef869ff29c1df350b4780c.zip
authsae 80211s authentication daemon
This patch adds authsae open80211s authentication daemon (http://open80211s.org) It's a rework of Peter Naulls patch (http://patchwork.openwrt.org/patch/1350/) I've excluded the sample conf file as it's useless when used with mac80211.sh (Emanuel Taube patch) It now link against libnl-tiny instead of libnl (patch merged in authsae git) Authsae is 58 Ko (OPENSSL_WITH_EC option adds 35Ko to libopenssl) Signed-off-by: Peter Naulls <peter@chocky.org> Signed-off-by: Etienne CHAMPETIER <etienne.champetier@free.fr> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37553 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services/authsae')
-rw-r--r--package/network/services/authsae/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/package/network/services/authsae/Makefile b/package/network/services/authsae/Makefile
new file mode 100644
index 0000000000..c804803667
--- /dev/null
+++ b/package/network/services/authsae/Makefile
@@ -0,0 +1,42 @@
+
+# Copyright (C) 2007-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=authsae
+PKG_VERSION:=2013-07-24
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://github.com/cozybit/authsae.git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=f5693a3ee8dcc4e11d25acc4e75f5d154c0b302b
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+
+PKG_BUILD_PARALLEL:=1
+CMAKE_INSTALL:=1
+
+CMAKE_OPTIONS += -DSYSCONF_INSTALL_DIR=/etc
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/authsae
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=80211s mesh security
+ DEPENDS=+libopenssl +libconfig +libnl-tiny +@OPENSSL_WITH_EC
+endef
+
+TARGET_CFLAGS += -D_GNU_SOURCE
+
+define Package/authsae/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
+endef
+
+$(eval $(call BuildPackage,authsae))