aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/ipv6
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2015-12-27 20:42:26 +0000
committerHauke Mehrtens <hauke@openwrt.org>2015-12-27 20:42:26 +0000
commitb57bcf8aa03f03c3d127bbb4c963ee39d04d709f (patch)
tree31b7566b0a66fa9d766536bc120364cc043a3a97 /package/network/ipv6
parentd7c76d4e38374e002aad4732af17d7fc39cf3bbf (diff)
downloadmaster-187ad058-b57bcf8aa03f03c3d127bbb4c963ee39d04d709f.tar.gz
master-187ad058-b57bcf8aa03f03c3d127bbb4c963ee39d04d709f.tar.bz2
master-187ad058-b57bcf8aa03f03c3d127bbb4c963ee39d04d709f.zip
6in4: Corrected tunnelbroker tunnel update URL
Changed the tunnel update URL into format tunnelbrokers example has, that made it work again. Current method gives "Username/Password Authentication Failed." when I tried the wget line manually and logread eventually says also "6in4: update failed". With corrected URL it works fine: "good 111.222.333.444" or "nochg 111.222.333.444" and logread concurs with success, and tunnel actually updates. Tested-by: Vaasa Hacklab <info@vaasa.hacklab.fi> Signed-off-by: Sami Olmari <sami@olmari.fi> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48006 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/ipv6')
-rw-r--r--package/network/ipv6/6in4/Makefile2
-rwxr-xr-xpackage/network/ipv6/6in4/files/6in4.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/network/ipv6/6in4/Makefile b/package/network/ipv6/6in4/Makefile
index 9eca57af63..b51b12d482 100644
--- a/package/network/ipv6/6in4/Makefile
+++ b/package/network/ipv6/6in4/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6in4
-PKG_VERSION:=22
+PKG_VERSION:=23
PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0
diff --git a/package/network/ipv6/6in4/files/6in4.sh b/package/network/ipv6/6in4/files/6in4.sh
index 59747a3783..05471db14b 100755
--- a/package/network/ipv6/6in4/files/6in4.sh
+++ b/package/network/ipv6/6in4/files/6in4.sh
@@ -108,7 +108,7 @@ proto_6in4_setup() {
fi
}
- local url="$http://ipv4.tunnelbroker.net/nic/update?username=$username&password=$password&hostname=$tunnelid"
+ local url="$http://$username:$password@ipv4.tunnelbroker.net/nic/update?hostname=$tunnelid"
local try=0
local max=3