aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/ipv6
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-06-27 10:40:44 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-06-27 10:40:44 +0000
commit5b32f12d226034077dc63b44060481329be2d354 (patch)
tree619bde9c95f9554156e0d31443cc71edba62e715 /package/network/ipv6
parent3f6bbd28589147b53d0ede0e4102deebf311614a (diff)
downloadmaster-187ad058-5b32f12d226034077dc63b44060481329be2d354.tar.gz
master-187ad058-5b32f12d226034077dc63b44060481329be2d354.tar.bz2
master-187ad058-5b32f12d226034077dc63b44060481329be2d354.zip
6in4: send password unhashed
The preferred he.net /nic/update endpoint expects the password or updatekey in plain text and not as md5 sum, therfore remove the hashing operation from the script. This effectively renders the "updatekey" option redundant but we keep it around for backwards compatibility. Both "option password" and "option updatekey" will have end up in the "&password=" parameter of the update url and are passed through unmodified. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41358 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/ipv6')
-rw-r--r--package/network/ipv6/6in4/Makefile2
-rwxr-xr-xpackage/network/ipv6/6in4/files/6in4.sh6
2 files changed, 2 insertions, 6 deletions
diff --git a/package/network/ipv6/6in4/Makefile b/package/network/ipv6/6in4/Makefile
index bd999721d8..1235ce5335 100644
--- a/package/network/ipv6/6in4/Makefile
+++ b/package/network/ipv6/6in4/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6in4
-PKG_VERSION:=16
+PKG_VERSION:=17
PKG_RELEASE:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/6in4/files/6in4.sh b/package/network/ipv6/6in4/files/6in4.sh
index f9434936e3..5309cc4a5f 100755
--- a/package/network/ipv6/6in4/files/6in4.sh
+++ b/package/network/ipv6/6in4/files/6in4.sh
@@ -1,6 +1,6 @@
#!/bin/sh
# 6in4.sh - IPv6-in-IPv4 tunnel backend
-# Copyright (c) 2010-2012 OpenWrt.org
+# Copyright (c) 2010-2014 OpenWrt.org
[ -n "$INCLUDE_ONLY" ] || {
. /lib/functions.sh
@@ -63,10 +63,6 @@ proto_6in4_setup() {
proto_send_update "$cfg"
[ -n "$tunnelid" -a -n "$username" -a \( -n "$password" -o -n "$updatekey" \) ] && {
- [ "${#password}" == 32 -a -z "${password//[a-fA-F0-9]/}" ] || {
- password="$(echo -n "$password" | md5sum)"; password="${password%% *}"
- }
-
[ -n "$updatekey" ] && password="$updatekey"
local url="http://ipv4.tunnelbroker.net/nic/update?username=$username&password=$password&hostname=$tunnelid"