aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/ipv6
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2012-12-11 16:56:37 +0000
committerSteven Barth <steven@midlink.org>2012-12-11 16:56:37 +0000
commit381b57a6ea6990b5ae7a5fd625581674fee2bb5f (patch)
tree3e36de8c28e899cf14becb50b926f90f953ff228 /package/network/ipv6
parent91b24ac85b004a0a0821c7f6c9a68633ee6b810d (diff)
downloadmaster-187ad058-381b57a6ea6990b5ae7a5fd625581674fee2bb5f.tar.gz
master-187ad058-381b57a6ea6990b5ae7a5fd625581674fee2bb5f.tar.bz2
master-187ad058-381b57a6ea6990b5ae7a5fd625581674fee2bb5f.zip
ipv6-support: Make ULA addresses secondary
* Deprecates ULA prefixes when there are other public prefixes * Fixes issues with clients using incorrect source addresses git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34630 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/ipv6')
-rw-r--r--package/network/ipv6/ipv6-support/Makefile2
-rw-r--r--package/network/ipv6/ipv6-support/files/support.sh4
2 files changed, 4 insertions, 2 deletions
diff --git a/package/network/ipv6/ipv6-support/Makefile b/package/network/ipv6/ipv6-support/Makefile
index a814b52fb6..d570e54fc4 100644
--- a/package/network/ipv6/ipv6-support/Makefile
+++ b/package/network/ipv6/ipv6-support/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ipv6-support
-PKG_VERSION:=2012-12-10
+PKG_VERSION:=2012-12-11
PKG_RELEASE:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/ipv6-support/files/support.sh b/package/network/ipv6/ipv6-support/files/support.sh
index 8e8458b888..f723e6e5a0 100644
--- a/package/network/ipv6/ipv6-support/files/support.sh
+++ b/package/network/ipv6/ipv6-support/files/support.sh
@@ -111,6 +111,7 @@ announce_prefix() {
local prefix="$1"
local network="$2"
local cmd="$3"
+ local type="$4"
local addr=$(echo "$prefix" | cut -d/ -f1)
local rem=$(echo "$prefix" | cut -d/ -f2)
@@ -140,6 +141,7 @@ announce_prefix() {
[ -z "$cmd" ] && cmd=newprefix
[ "$prefix_action" == "npt" ] && msg="$msg"', "npt": 1'
+ [ "$type" == "secondary" ] && msg="$msg"', "secondary": 1'
ubus call 6distributed "$cmd" "$msg}"
}
@@ -381,7 +383,7 @@ enable_ula_prefix() {
}
# Announce ULA
- [ -n "$ula_prefix" ] && announce_prefix "$ula_prefix" "$network"
+ [ -n "$ula_prefix" ] && announce_prefix "$ula_prefix" "$network" newprefix secondary
}