aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/ipv6
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2015-03-10 08:43:40 +0000
committerSteven Barth <steven@midlink.org>2015-03-10 08:43:40 +0000
commit2f9a22317c2a82877ea45cd0cc90b5ace679d201 (patch)
tree5128a061079d52437d050d22ff57ffa250bb8bb5 /package/network/ipv6
parent11fd3b9e42bd6ed3559fe803345e6b7b20506517 (diff)
downloadmaster-187ad058-2f9a22317c2a82877ea45cd0cc90b5ace679d201.tar.gz
master-187ad058-2f9a22317c2a82877ea45cd0cc90b5ace679d201.tar.bz2
master-187ad058-2f9a22317c2a82877ea45cd0cc90b5ace679d201.zip
6in4: make host dependency more specific
Signed-off-by: Steven Barth <steven@midlink.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44635 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/ipv6')
-rw-r--r--package/network/ipv6/6in4/Makefile2
-rwxr-xr-xpackage/network/ipv6/6in4/files/6in4.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/network/ipv6/6in4/Makefile b/package/network/ipv6/6in4/Makefile
index ef9691227a..21e69e6f49 100644
--- a/package/network/ipv6/6in4/Makefile
+++ b/package/network/ipv6/6in4/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6in4
-PKG_VERSION:=20
+PKG_VERSION:=21
PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0
diff --git a/package/network/ipv6/6in4/files/6in4.sh b/package/network/ipv6/6in4/files/6in4.sh
index f8a43ce24b..0289df3031 100755
--- a/package/network/ipv6/6in4/files/6in4.sh
+++ b/package/network/ipv6/6in4/files/6in4.sh
@@ -36,7 +36,7 @@ proto_6in4_setup() {
return
}
- ( proto_add_host_dependency "$cfg" 0.0.0.0 )
+ ( proto_add_host_dependency "$cfg" "$peeraddr" )
[ -z "$ipaddr" ] && {
local wanif