aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/ipv6/map
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2015-06-09 21:18:55 +0000
committerSteven Barth <steven@midlink.org>2015-06-09 21:18:55 +0000
commitcbd56e762df1dbfcc0670bc88f3a715d22405d59 (patch)
tree5f7f021b873874b6279bfa36f85ab4f72ef2418a /package/network/ipv6/map
parent63c1463654471cdd03f12147206338eced7699dc (diff)
downloadmaster-187ad058-cbd56e762df1dbfcc0670bc88f3a715d22405d59.tar.gz
master-187ad058-cbd56e762df1dbfcc0670bc88f3a715d22405d59.tar.bz2
master-187ad058-cbd56e762df1dbfcc0670bc88f3a715d22405d59.zip
map: add sleep work-around for lw4o6 race-condition
Signed-off-by: Steven Barth <steven@midlink.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45936 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/ipv6/map')
-rw-r--r--package/network/ipv6/map/Makefile2
-rwxr-xr-xpackage/network/ipv6/map/files/map.sh3
2 files changed, 4 insertions, 1 deletions
diff --git a/package/network/ipv6/map/Makefile b/package/network/ipv6/map/Makefile
index 89d34de1b4..3757ed6088 100644
--- a/package/network/ipv6/map/Makefile
+++ b/package/network/ipv6/map/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=map
PKG_VERSION:=4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/map/files/map.sh b/package/network/ipv6/map/files/map.sh
index 5e37aa25b3..98a493dd57 100755
--- a/package/network/ipv6/map/files/map.sh
+++ b/package/network/ipv6/map/files/map.sh
@@ -39,6 +39,9 @@ proto_map_setup() {
( proto_add_host_dependency "$cfg" "::" "$tunlink" )
+ # fixme: handle RA/DHCPv6 address race for LW
+ [ "$type" = lw4o6 ] && sleep 5
+
if [ -z "$rule" ]; then
rule="type=$type,ipv6prefix=$ip6prefix,prefix6len=$ip6prefixlen,ipv4prefix=$ipaddr,prefix4len=$ip4prefixlen"
[ -n "$psid" ] && rule="$rule,psid=$psid"