aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2016-07-21 08:35:15 +0200
committerGitHub <noreply@github.com>2016-07-21 08:35:15 +0200
commit3f40c83a32466603c4aea2625510aba6921b1a44 (patch)
tree4602b0b85b3791f9b424368d221e95b0cf0120d8 /package/network/config
parent5a7639c2f620aebe30df18af42d61eb5307f4d6d (diff)
parent0881b27ea0d2b4bdad03b1b3d564188702a6c019 (diff)
downloadmaster-187ad058-3f40c83a32466603c4aea2625510aba6921b1a44.tar.gz
master-187ad058-3f40c83a32466603c4aea2625510aba6921b1a44.tar.bz2
master-187ad058-3f40c83a32466603c4aea2625510aba6921b1a44.zip
Merge pull request #37 from wigyori/master
Pull req for mwlwifi, archs38, bcm53xx and core package updates
Diffstat (limited to 'package/network/config')
-rw-r--r--package/network/config/netifd/Makefile4
-rwxr-xr-xpackage/network/config/netifd/files/lib/netifd/proto/dhcp.sh6
2 files changed, 5 insertions, 5 deletions
diff --git a/package/network/config/netifd/Makefile b/package/network/config/netifd/Makefile
index 514eedd885..82fcb3e48e 100644
--- a/package/network/config/netifd/Makefile
+++ b/package/network/config/netifd/Makefile
@@ -1,13 +1,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=netifd
-PKG_VERSION:=2016-03-31
+PKG_VERSION:=2016-06-06
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(OPENWRT_GIT)/project/netifd.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=39d9ceeb96162a83a3f5fa63e6aaa1ccb38caa62
+PKG_SOURCE_VERSION:=99e6dc68bbac5a57a0ebca810a9dc36e38667821
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
# PKG_MIRROR_MD5SUM:=
diff --git a/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh b/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh
index 7f4af25329..abfdaaffdd 100755
--- a/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh
+++ b/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh
@@ -54,10 +54,10 @@ proto_dhcp_setup() {
proto_run_command "$config" udhcpc \
-p /var/run/udhcpc-$iface.pid \
-s /lib/netifd/dhcp.script \
- -f -R -t 0 -i "$iface" \
+ -f -t 0 -i "$iface" \
${ipaddr:+-r $ipaddr} \
- ${hostname:+-H $hostname} \
- ${vendorid:+-V $vendorid} \
+ ${hostname:+-H "$hostname"} \
+ ${vendorid:+-V "$vendorid"} \
$clientid $broadcast $release $dhcpopts
}