aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/swconfig
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-07-17 12:51:24 +0000
committerJohn Crispin <blogic@openwrt.org>2015-07-17 12:51:24 +0000
commit70dc6dced4b36b350e8ffffd6a3ac73e730cefb4 (patch)
treeb0c7db75b7fb8d3c053b056ed88ade3cfb45f095 /package/network/config/swconfig
parent69cb00bb453f7262ce6a945722c5bcd604a74112 (diff)
downloadmaster-187ad058-70dc6dced4b36b350e8ffffd6a3ac73e730cefb4.tar.gz
master-187ad058-70dc6dced4b36b350e8ffffd6a3ac73e730cefb4.tar.bz2
master-187ad058-70dc6dced4b36b350e8ffffd6a3ac73e730cefb4.zip
swconfig: libsw.so should be installed into /usr/lib/
otherwise it's not picked up by toolchain: staging_dir/toolchain-mipsel_24kec+dsp_gcc-4.8-linaro_musl-1.1.10/lib/gcc/mipsel-openwrt-linux-musl/4.8.3/../../../../mipsel-openwrt-linux-musl/bin/ld: cannot find -lsw Signed-off-by: Roman Yeryomin <roman@advem.lv> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46406 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/config/swconfig')
-rw-r--r--package/network/config/swconfig/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/config/swconfig/Makefile b/package/network/config/swconfig/Makefile
index 3c2ec3e387..b62b059873 100644
--- a/package/network/config/swconfig/Makefile
+++ b/package/network/config/swconfig/Makefile
@@ -46,8 +46,8 @@ define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_BUILD_DIR)/swlib.h $(1)/usr/include/
- $(INSTALL_DIR) $(1)/lib
- $(CP) $(PKG_BUILD_DIR)/libsw.so $(1)/lib/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/libsw.so $(1)/usr/lib/
endef
define Package/swconfig/install